Jump to content

[RESOLU] Nagios, erreur "could not complete SSL handshake"


Recommended Posts

Salut,

Depuis plusieurs semaines je suis sur un projet d'installer un serveur de supervision sous Nagios.

Pour superviser les serveurs Windows, aucun problème.

En revanche, impossible de superviser certains services (mémoire, espace disque...) d'hôtes Linux. En effet, lorsque je fais la commande (l'adresse IP X.X.X.X est l'hôte et Y.Y.Y.Y est le serveur Nagios):

/usr/lib/nagios/plugins/check_nrpe -H X.X.X.X

L'erreur suivante s'affiche :

CHECK_NRPE: (ssl_err != 5) Error - Could not complete SSL handshake with X.X.X.X

La solution que je trouve le plus souvent est d'aller dans le fichier/etc/nagios/nrpe.cfg dans le serveur hôte et de modifier la ligne :

allowed_hosts=127.0.0.1

En :

allowed_hosts=127.0.0.1,Y.Y.Y.Y

Ce que j'ai fait, sans succès.

J'ai vérifié également si openssl est activé sur les deux serveurs, les versions de NRPE (ce sont les mêmes) et ai ajouté l'adresse IP du serveur Nagios dans le fichier/etc/hosts.allow.

Je suis un peu coincé pour le moment donc si quelqu'un a une idée...

Les serveurs sont sous Ubuntu.

Merci par avance !

Edited by LordWolfy
Link to post
Share on other sites

Moi je tenterai d'aller voir dans /etc/xinetd.d/nrpe

et ensuite je modifierai la ligne only_from en rajoutant Y.Y.Y.Y à 127.0.0.1

Si beaucoup de machine tu peux aussi rajouter une ligne dans le fichier :

 

	only_from += Y.Y.Y.Y
	

Ça te permet de pousser ton ip de serveur nagios.

Ensuite tu tentes un service xinetd restart

tu a bien fait un restart du daemon nrpe après tes modifs ?

Tu a installé comment nrpe sur tes ubuntu ? => https://support.nagios.com/kb/article.php?id=515#Ubuntu

 

Edited by Totone
Link to post
Share on other sites

Désolé de répondre aussi tard.

@Totone

J'ai bien /etc/xinetd.d/ mais pas de /etc/xinetd.d/nrpe

Faut-il télécharger quelque chose supplémentaire ?

J'avais installé les services "nagios-nrpe-server" et "nagios-plugins" sur les serveurs à superviser. J'avoue que service nrpe restart ne fonctionne pas mais "service nagios-nrpe-server" fonctionne bien...

Sur le serveur Nagios, j'ai installé "nagios-nrpe-plugin"

@L33thium

Il faudra que je regarde ça demain.

Edited by LordWolfy
Erreur dans les noms
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...