Jump to content
crocodudule

[RESOLU] Deux routeurs sur le réseau qui se genent mutuellement

Recommended Posts

Bonjour à tous.

J'ai une difficulté qui est la suivante:

J'ai une box (freebox) en mode routeur et le wifi activé.

Précisément, le wifi ne couvrant pas l'ensemble de la maison j'ai tiré un cable rj 45 le plus loin possible et sur cette prise j'ai connecté un petit routeur TP-LINK wifi (en mode point d'accès et un 2°nom de réseau wifi).

Les deux réseaux sont sur des plages différents:
. box sur 192.168.0.X
. TP-LINK sur 192.168.10.X

Malgré ces deux plages, ils arrivent que certains appareils utilisant le DHCP (nécessaire) se connectant sur le wifi de la box prennent une IP et le gateway du TP-LINK et inversement. Naturellement, cela ne fonctionne pas...

J'ai encore tenté de placer le routeur TP-LINK dans la zone DMZ pour totalement cloisonner, mais du coup le TP-LINK ne peut plus non plus dialoguer avec la box et donc aller sur le net.

Je présume qu'une solution pourrait être de jouer avec d'autres plages réseaux et masques mais je ne maîtrise pas suffisamment ce domaine.

C'est pourquoi je fais appel à vos lumières.

Merci 🙂

 

 

Edited by crocodudule

Share this post


Link to post
Share on other sites

Le tp-link est sans doute configurable en tant que bridge.
Il ne gérera que l’authentification wifi et toutes les requêtes seront envoyées à la box (dhcp, broadcast, tout ça)

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 8 heures, L33thium a écrit :

Le tp-link est sans doute configurable en tant que bridge.
Il ne gérera que l’authentification wifi et toutes les requêtes seront envoyées à la box (dhcp, broadcast, tout ça)

Comme toujours merci pour ton intervention, je regarde ça et surtout me renseigne sur ce qu'est le mode bridge ! (Si ca permet de résoudre la difficulté, je l'indiquerai naturellement).
Merci encore 😀

Edited by crocodudule

Share this post


Link to post
Share on other sites

bridge ou point d'accès, de sorte qu'il ne gère pas le routage tout simplement, aucun service actif comme dhcp dessus, ce sera la box seule qui attribuera toutes les adresses

Share this post


Link to post
Share on other sites

Il faut configurer ton TP Link en passerelle tu met l'IP de ta box . Et les que le DHCP fourni par ton TP Link soit la même plage IP . Par contre, sur ta freebox, la plage dhcp de 192.168.1.10 à 50 et tp link de 51 à 100.

 

Share this post


Link to post
Share on other sites

Autre solution à mon avis plus simple : met le TP-LINK sur le même réseau que la box. Met lui une adresse dans 192.168.0.X (unique bien sûr) et désactive le DHCP.

Ensuite relie le routeur TP-LINK à la box en utilisant un des ports LAN, le port WAN du TP-LINK ainsi que sa fonction routeur n'est plus utilisé, juste le switch et le Wifi.

Tu n'auras plus qu'un seul réseau avec deux points Wifi et un seul DHCP (important).

Normalement en mettant les même paramètres sur les deux points d'accès Wifi tu devrais pouvoir passer de l'un à l'autre mais je n'ai jamais fait ce genre de config.

Plus d'infos : https://forum.nextinpact.com/topic/166600-le-wifi-le-comprendre-le-faire-marcher/

 

Share this post


Link to post
Share on other sites

J'avais déjà installé le TP-LINK en mode AP et en cloisonnant les plages IP.

Malgré cela il arrivait que l'appareil utilise le wifi de la box pour se connecter mais obtienne une IP (outre la passerelle) du TP-LINK et inversement.

En revanche, je confirme, le mode bridge semble parfaitement fonctionner :)

Share this post


Link to post
Share on other sites

Je ne comprends pas : si tu fais ce que dit RalphAstronome, le DHCP du TP-LINK est désactivé et ne donne plus du tout d'adresse... Il ne sert que de relais et seule la box attribue les adresses.

Share this post


Link to post
Share on other sites
Il y a 10 heures, RFN a écrit :

Je ne comprends pas : si tu fais ce que dit RalphAstronome, le DHCP du TP-LINK est désactivé et ne donne plus du tout d'adresse... Il ne sert que de relais et seule la box attribue les adresses.

Si en mode AP je désactive le DHCP du TP-LINK, pour des raisons que j'ignore, les appareils n'obtiennent pas d'IP via le DHCP auprès de la box (par contre si j'en mets une en dur je communique sans problème).

En revanche en mode bridge (qui n'a pas ce nom là exactement mais qui est le nom du mode bridge pour ce modèle, de mémoire quelque chose avec S et W dans le nom, (l’installation n'étant pas chez moi je ne me souviens plus exactement)) et en indiquant dans les options du TP-LINK que la passerelle est la box, alors ça fonctionne parfaitement (option qui ne semble pas être prise en compte en mode AP, peut être un firmware a mettre à jour, mais bon peu importe le mode bridge fonctionne nickel).

Edited by crocodudule

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...