Jump to content
Aloyse57

G-Sync : FPS instables

Recommended Posts

Salut,

J'ai échangé contre un rein, mon écran Acer T272HUL (27'' Touch 2560x1440 @60Hz) pour un tout nouveau Acer X34P (34'' 3440x1440 @100Hz G-Sync). Pas de problème dans l'utilisation quotidienne bureautique.
Par contre j'ai un soucis dans mon jeu principal (WorldOfWarShip) : avec la même résolution fenêtrée et les mêmes réglages, j'avais 60FPS stables avec mon écran non-GSync tandis qu'avec mon nouvel écran j'oscille entre 75FPS et 35FPS. Des fois je reste toute une partie (~15mn) à 75Hz, des fois ça tombe à 35-45 FPS instables. J'ai essayé de désactiver le V-Sync : pas d'effet. J'ai OC ma carte (EVGA 980TI HYBRID), ça a l'air d'aller mieux.

Est-ce que la techno G-Sync agit sur le GPU défavorablement ? Est-ce qu'on peut désactiver G-Sync pour faire des tests (je n'ai pas trouvé comment faire ) ?

P.S. 1/je joue habituellement en 2400x1280. 2/Avec mon nouvel écran, le problème est le même en non-fenêtré, fenêtré, full résolution ou pas. 3/J'ai un second moniteur USB 3 éteint quand je joue.

 

Share this post


Link to post
Share on other sites

Salut,

Alors déjà ton écran est en 100 Hz, si dans ton jeu tu n'arrives pas à 100 fps en constant, désactive V-Sync.

Ensuite désactiver G-Sync ne me parait pas être une bonne idée... C'est ballot de payer (cher) cette techno pour la désactiver :(
Est-ce que du coup G-Sync est bien actif (ça peut se régler par programme dans "Gérer les paramètres 3D") ? Car l'un de ses points forts c'est justement de ne pas te laisser voir quand il y a des variations de FPS.

604477GSync.jpg

Share this post


Link to post
Share on other sites

V-Sync désactivé, G-Sync idem dans mon panneau nVidia.

Le truc qui m'intrigue, c'est que les variations n'ont pas l'air d'être liés à la résolution, que je joue en 2400x1280, en 3440x1440 fenêtré, ou en 3440x1440 full screen. Je vais continuer mes tests, quitte à couper le G-Sync au niveau moniteur (si c'est possible), jouer sur l'OC de la carte vidéo, ou baisser les effets (je joue au max). Pour tant j'aurais cru qu'une 980Ti pouvait tenir du 2K.

L'année prochaine une 2080Ti, p-ê :transpi:

Share this post


Link to post
Share on other sites
Il y a 3 minutes, Aloyse57 a écrit :

V-Sync désactivé, G-Sync idem dans mon panneau nVidia.

Le truc qui m'intrigue, c'est que les variations n'ont pas l'air d'être liés à la résolution, que je joue en 2400x1280, en 3440x1440 fenêtré, ou en 3440x1440 full screen. Je vais continuer mes tests, quitte à couper le G-Sync au niveau moniteur (si c'est possible), jouer sur l'OC de la carte vidéo, ou baisser les effets (je joue au max). Pour tant j'aurais cru qu'une 980Ti pouvait tenir du 2K.

L'année prochaine une 2080Ti, p-ê :transpi:

C'est possible que ta carte aime pas trop monter à 100FPS sur le jeu et que ça amenne la carte à freezer. Tu peux bloquer le nombre de FPS à 60 dans les options ?

Edited by Chocobidou

Share this post


Link to post
Share on other sites

Salut, essaie avec nvinspector de vérouiller les fps à 99 ou directement dans le jeu si l'option est disponible, juste vérouiller les fps en laissant la Vsync désactivé.

J'ai cru lire je ne sais plus ou je vais chercher, que G-sync partait en cou*lle quand on dépassait le framerate de l'écran justement, d'ou le vérouillage via nvinspector ou directement dans le jeu

Edited by Banguefu

Share this post


Link to post
Share on other sites

Hello,

dommage, je n'ai pas trouvé l'intervalle de rafraichissement vertical de cet écran.

Sinon, il doit être branché en Display Port pour une bande passante maxi et une latence + faible (face à sa connexion HDMI 1.4).
Il supporte le DP 1.2, ce qui veut dire 1 seul écran 4K et au max 2 écrans 2560*1600. C'est quoi ce moniteur branché en USB ? Tu as essayé sans ce dernier ?

Si tu as le Fast Boot pour Win 10 activé, désactives-le et faire un vrai reboot (arrêt complet et redémarrage complet).
Tentes aussi en ne mettant que l'option Full screen dans le panneau nVidia (donc l'option sans le mode fenêtré).

Une 980 Ti c'est trop court pour du 4K. Ca vaut une 1070 GTX, pas +. Sur des jeux lourd pour la 980 Ti, la CG peut ne pas savoir gérer le G-Sync si l'écran n'est pas capable de descendre sous les 35 IPS par exemple (Cf. 1ère remarque).

Share this post


Link to post
Share on other sites

J'espère pour toi que ce n'est pas le bug lorsqu'on est en dual screen avec 2 moniteurs ayant des fréquences de refresh différents :transpi: 

Tu vas devoir appuyer sur la touche Windows et remettre le focus de la fenêtre en 1er plan pour avoir les fps au max à nouveau :fumer: à chaque fois

Share this post


Link to post
Share on other sites

Ok pour ce premier point.

Mais pour :
Si tu as le Fast Boot pour Win 10 activé, désactives-le et faire un vrai reboot (arrêt complet et redémarrage complet).
Tentes aussi en ne mettant que l'option Full screen dans le panneau nVidia (donc l'option sans le mode fenêtré).
Tu as essayé ? 

Share this post


Link to post
Share on other sites

Bon, je poursuis dans le debug.

Win10, pas de fastboot sur mes machines. Quand je souhaite les éteindre, je veux qu'elles s'éteignent :ane:.
Tests : jeu testé 3 parties=45mn, réglages identiques
FullScreen + G-Sync Fullscreen : 75FPS stable
Fullscreen + (G-Sync Fullscreen + windowed) : 75FPS stable
Windowed + (G-Sync Fullscreen + windowed) : 75-35FPS instable (quelque soit la résolution 3440->1940)

JE vais tester ce qui est dit ici : https://www.blurbusters.com/gsync/gsync101-input-lag-tests-and-settings/14/

Share this post


Link to post
Share on other sites

Ok, en attente du reste des tests mais on est bien quand on est hors mode fenêtré dans les param nVidia donc.

Share this post


Link to post
Share on other sites

Suite et fin de mes aventures.

J'ai essayé toutes sortes d'autres configurations, mais ça ne fonctionnait pas, y compris en ramenant mon moniteur à sa fréquence normale de 100Hz.
Cependant en jouant à WorldOfTanks, je me suis aperçu que je pouvais grimper à 100FPS ; je suis alors revenu à WorldOfWarShips et là bim, FPS instables de nouveau.
J'ai donc écumé les forums du jeu pour voir s'il n'y avait pas quelqu'un qui avait soumis un problème semblable et j'ai trouvé un commentaire à propos d'un paramètre limitant les FPS dans le jeu. Je l'ai cherché avec l'idée de mettre 60FPS suivant le commentaire de @Banguefu ; j'ai trouvé le fameux paramètre et sa valeur par défaut était 75.
J'ai décidé de mettre 100 et de refaire un dernier essai : tada, FPS entre 80 et 99 ! Du coup, j'ai remis le moniteur à 120Hz, indiqué 120 dans le paramètre et relancé le jeu.

Plus de problème, j'oscille entre 100 et 120 FPS en fenêtré :auto:. Quelle idée d'avoir caché ça dans un obscur fichier de config !

Merci à tous.

  • Like 1

Share this post


Link to post
Share on other sites

Contgent pour toi et merci d'avoir posté ta solution.

Mais, juste une question : il me semble que dans le premier post tu parles du "monde des bateaux de guerre" pas du "monde des chars d'assault".

Share this post


Link to post
Share on other sites

Je joue principalement maintenant avec la version "Bateaux". Mais au commencement, la compagnie a créé le jeu de "Chars" auquel j'ai joué longtemps et auquel je joue encore.

Il existe même la version "Avions", qui est très difficile je trouve ; il faut un joystick sérieux, sinon, tu ne peux rien faire à part mourir.

J'ai un Saitek X52 Pro pour jouer à la version "World of WarPlanes".

Il existe un nouveau moteur graphique appelé WoT enCore : il donne un rendu fabuleux.

Share this post


Link to post
Share on other sites

Alors pour ceux à qui ça intéresse en résumé :

  • Penser à régler les FPS minimum à la même valeur que les FPS max.
  • Eviter le jeu en fenêtré dans la mesure du possible 
  • Désactiver le fast boot ( solution qui a fonctionné à une certaine période ... )
  • Eviter le dual screen
  • Mettre à jour Windows et Forceware ( Nvidia en a marre, et ne veut plus attendre Microsoft. Des "correctifs" sont appliqués sur  les derniers drivers, mais vu que Windows change le comportement du support de la synchro vertical c'est pas gagné pour nous les consommateurs :fumer: )
  • Désactiver GSync, c'est balo mais ça fonctionne :transpi: 

 

  • Haha 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...