Jump to content

Archived

This topic is now archived and is closed to further replies.

Ulfr Sarr

scp - Permission denied (publickey...

Recommended Posts

Bonjour,

 

J'ai un petit problème de copie de fichiers entre deux machine sous linux (le machine A en RHEL7.0 et la machine B en RHEL6.2). J'ai fouillé sur le net mais là je commence à sérieusement manquer d'idées...

 

Sur la machine A, j'ai un shell qui déplace des fichiers d'un répertoire de A dans un autre et qui dans la foulée copie ces mêmes fichiers sur un serveur B.

 

J'ai mis en place sur B le authorized_keys ce qui me permet de faire ma copie scp depuis A en ligne de commande sans avoir à entrer de password.

 

gallery_60548_338_4179.png

 

 

 

 

Par contre, quand je veux effectuer la même opération en batch, j'ai une erreur : 

 

gallery_60548_338_459.png
 
 
Dans le batch, le scp est appelé comme ça :
 
scp -B -i /home/pec119/.ssh/id_rsa "$entry" p119@p119-prod-app:~/"$fileName"
 
Ma question, c'est pourquoi ça tout se passe bien en ligne de commande et pas en batch?
Link to post
Share on other sites

ça vaudrait peut-être le coup de faire un fichier .ssh/config avec la config du serveur (avec public_key...) et lancer juste un scp serveur ensuite sans mettre aucune option concernant la connexion (scp récupérera les infos du fichier config)?

Link to post
Share on other sites

J'ai crée un .ssh/config avec les mêmes infos que dans le shell puis j'ai modifié le shell pour ne plus passer d'info de connexion.. Et ça fonctionne...

 

Je ne comprends absolument pas pourquoi mais ça fonctionne.

 

Merci  :incline:

Link to post
Share on other sites

Je ne comprends absolument pas pourquoi mais ça fonctionne.

 

Je suppose que ça ne fonctionne pas à l'origine parce que la clef utilisée est enregistrée dans le fichier authorized_keys de l'utilisateur pec119 et que tu essaie de te connecter avec l'identifiant p119. Donc ça fonctionne quand tu ne spécifie pas de nom d'utilisateur (scp utilise pec119 par défaut).

Link to post
Share on other sites

×
×
  • Create New...