Jump to content

Archived

This topic is now archived and is closed to further replies.

Meeeed

Erreur pour formater et créer partition ext4 debian wheezy

Recommended Posts

Bonjour à tous,

Je fait de l'admin 'occasionelle mais complete' linux depuis une 10aine d'années, exclusivement en ssh. Mon dernier fsck remonte à trés loin.

Je viens de prendre un serveur chez ovh ( pour la xieme fois ), debian wheezy nue, ajout de ispconfig pour l'oeil, mongo node apache mail tout roule.

Enfin non, tout ne roule pas : j'ai fauté severe au moment de choisir le partitionnement, et je ne peux relancer une install car j'héberge déja des mails.

Je me retrouve donc avec :

- Quatre ssd de 120Go montés en 2 couples raid1 ( pour ça, tant pis, / est dessus )

- Deux disques de 2To chacun inutilisés, et initialement ( semble t'il ) prévus pour du raid ( flags 'raid' dans parted, même uuid, même label 'data' , mais absent de mdadm.conf et de fstab et mdstat )

Impossible de monter ces volumes ! je n'ai plus de piste.

Actions : tenté de reformater les hdd, recréer partition à partir de 4096, pas d'erreur. Regénération des UUID des disques qui étaient identiques, impossible de supprimer le label ( vu dans blkid ), qui était identique pour les deux => changement du label pour chacun.

Erreurs depuis le début :

- sur un mount : wrong fs type, bad option, bad superblock on /dev/sdc1 ....

- parted : ne veut pas bosser sur du ext4

- fdisk : n'aime pas GPT, me conseille parted

- dmesg : VFS: Can't find ext4 filesystem

extrait blkid pour /dev/sdc et /dev/sdd

/dev/sdc1: Tiens donc, je viens juste d'effacer la table GPT ( tune2fs, mkfs, fdisk ? greu )

/dev/sdd1: LABEL="data1" UUID="2222edd6-99c3-4f93-a0ad-c0dc2a277de3" TYPE="ext4"

extrait LSBLK -f :

sdc
`-sdc1 ext4 data1
sdd
`-sdd1 ext4 data2

Je viens bien sur de passer quelques jours sur l'internet, sans bonne pioche.

Juste que le client n'est pas content, car le client, c'est moi !

Si vous avez une piste, j'en suis preneur volontiers !!

Merci.

Share this post


Link to post
Share on other sites

Salut et bienvenu !

J'ai pas trop compris, as-tu essayer de reconstruire le raid avec mdadm ?

Share this post


Link to post
Share on other sites

Hello !

Oui, mais ça a juste été une étape.

Je n'arrivais pas à faire monter les volumes ( erreurs identiques ), et comme mes sauvegardes se feront ailleurs j'ai donc préféré récupérer deux hdd de 2 to, en espérant que cela resolve l'impossibilité de montage ... mais non.

Voila.

edit :

pour répondre à la question : oui, mais aprés l'avoir reconstruire, nenette

Share this post


Link to post
Share on other sites

×
×
  • Create New...