Jump to content

Archived

This topic is now archived and is closed to further replies.

Raikoryu

[RESOLU] Pas de dual boot après installation de Linux Mint

Recommended Posts

Bonjour à tous,

En suivant une vidéo vue sur le web, j'ai installé Linux Mint sur le disque dur de mon PC qui servait de backup à Windows 7 avec la fonction native du système. J'ai donc consacré 40 Go de ce disque de 500 Go à la partition /, 30 Go à la partition /home, et 4 Go à la partition swap. J'ai trouvé étrange qu'il créée pas de partition /boot dans la vidéo, mais j'ai quand même suivi.

J'ai deux problèmes:

1/ Linux a effacé tout le contenu de mon disque physique. Au lieu de réduire l'espace de la partition existante, il a laissé le reste de l'espace en Unallocated space. Je ne comprends pas pourquoi (même si je sais que c'est irréversible...)

2/ Je n'ai pas de dual boot au démarrage, le PC boote directement sur Windows. J'ai cru comprendre que le dual boot s'appelle grub (et oui, on a tous été débutants un jour et moi c'est aujourd'hui!), mais jusqu'à présent il ne s'est pas manifesté. Puis-je régler ça sans tout réinstaller?

Merci d'avance.

Share this post


Link to post
Share on other sites

Bizarre , j'ai moi même installé Mint sur mon laptop avec seven et sans avoir fait de manipe particulière , j'ai au boot le choix entre les deux....

Tu a peut être eu un problème à l'installation , par contre je ne sais pas le résoudre ( moi aussi je débute avec Linux )

Share this post


Link to post
Share on other sites

Salut,

essaye de recréer le grub comme expliqué ici http://doc.ubuntu-fr.org/tutoriel/comment_restaurer_grub

tu as un autre disque dur ?

si oui il a peut être installe grub sur le mauvais ... tu dois pouvoir régler çà en changeant le disque dur principal dans le bios.

si c'est windows qui et dit :"Unallocated space" c'est normal il ne comprend pas les partitions EXT*.

Share this post


Link to post
Share on other sites

Alors, déjà une réinstallation complète n'a rien changé.

J'ai essayé avec le CD SuperGrub, mais lorsque je demande la détection des OS, il m'affiche sur fond noir error: unrecognized fs.

Avec le CD Boot Repair Disk, il se bloque pendant la détection des OS.

Quant à la méthode 1.3, elle me parraît trop longue et compliquée.

Je crois que la build 12 de Mint est foireuse, encore une ènième preuve qui confime mon hypothèse irréfutable que Linux est un OS qui ne fonctionne pas. je vais essayer d'en installer une autre. :o

Edit: J'ai aussi essayé d'appliquer cette solution, mais de un, le mec précise qu'il ne faut l'appliquer que si on n'a qu'un seul disque physique (ce qui n'est pas mon cas), et de deux, je ne sais pas comment obtenir "X" qui est le numéro de ma "sda" (kézaco)?

Share this post


Link to post
Share on other sites

sdxy correpond à la partition y sur le disque x ;-)

Pour l'obtenir je ne connais plus la ligne de commande dsl :/

Share this post


Link to post
Share on other sites

Xaelias : en principe on a les numéros en comptant les partitions, ou même simplement en démarrant un Live CD / USB de Linux ;)

Share this post


Link to post
Share on other sites

Ouai alors moi en général sur le DD où j'installe linux, je ne comptes pas les partition à la main ^^

Sinon oui y'a bien sûr le moyen de passer par le gestionnaire de disque ou je ne sais trop quoi, et de les afficher.

Mais je croyais me souvenir qu'il y avait une commande ;-)

Share this post


Link to post
Share on other sites

Je crois que la build 12 de Mint est foireuse, encore une ènième preuve qui confime mon hypothèse irréfutable que Linux est un OS qui ne fonctionne pas. je vais essayer d'en installer une autre. :o

La version 12 ( KDE ) est une RC donc c'est normal qu'il puisse y avoir encore quelques bug :transpi: Tu aurai du prendre la version 11 pour commencer avec Linux :roll:

Peut être que Easy BCD pourrai te sortir de là....Mais pas sur.

Share this post


Link to post
Share on other sites

Bon, là j'ai pris Linux Mint Debian Edition en espérant que ce soit quasiment la même chose niveau interface graphique. Par contre, j'ignore pourquoi cette distrib' ne dispose pas d'uneoption pour créer un espace swap au moment de l'install...

Edit: Même résultat avec Mint Debian, toujours pas de dual boot... :(

Pourtant j'avais bien vu une option "Install Grub" cochée pendant l'install!

Est-ce que le fait que je dédie un disque dur différent de celui qui contient Windows à Linux y est pour quelque chose?

Share this post


Link to post
Share on other sites

Salut,

juste quelques conseils avant d'installer Linux :

- réduire la partition Windows avec Windows, pas avec l'installateur de Linux ni avec un utilitaire Unix. Windows est le mieux à même d'effectuer cette tâche.

Et avant de le faire il peut être judicieux de faire une défragmentation du système de fichiers pour éviter toute perte de données.

- ne pas utiliser l'installateur de Linux pour partitionner ton disque dur. Il vaut mieux lui préférer un utilitaire de partitionnement dédié à cette tâche en live-cd.

Par exemple GParted, tu peux télécharger l'iso la plus récente de ce dernier ici.

Ensuite tu t'en sers pour préparer ton partitionnement avant même d'installer Linux : dans l'espace non-alloué tu crées ta partition racine (/), ta partition /home (perso j'en crée pas, je préfère une partition NTFS commune à Windows et Linux en NTFS) et ta partition swap (et tout ceci sans jamais toucher à la partition Windows qui a dû être redimensionnée avant cette étape) puis tu les formates (ext4 pour / et /home).

Au passage profites-en pour leur donner des noms (Labels/Etiquettes) pour t'aider à les identifier par la suite.

Par exemple appelle ta partition racine "Mint" et ta partition home "Home_Mint".

- ne pas faire une installation automatique mais manuelle : tu choisis l'option installation manuelle pour indiquer quelle est la partition racine, quelle est la partition home et quelle est la partition swap.

L'installateur Linux devrait identifier les partitions avec une dénomination du type sdxy. Le s indique que la partition est sur un dd sata (si c'était un disque ide le s serait remplacé par un h), le x correspond au périphérique de stockage (dd interne, dd externe, clé usb) relié à ta cm (a = 1er, b = 2e, etc.) et le y correspond au n° de la partition.

Pour connaître à l'avance quelle dénomination correspond à tes partitions /, /home et swap, lances un terminal dans une session live-cd et tapes la commande suivante : sudo blkid.

En retour tu devrais voir apparaître un certain nombre de lignes chacune correspondant à une partition d'un périphérique de stockage relié à ta cm (tous devraient être listés sans exception).

Généralement chaque ligne est composé des champs suivants :

/dev/sdxy = dénomination de la partition

LABEL = étiquette de la partition

UUID = chaîne alphanumérique qui identifie la partition de manière beaucoup plus fiable que sdxy (x peut changer suivant l'ordre dans lequel le périphérique de stockage a été branché, l'UUID lui ne change jamais)

TYPE = type de système de fichiers de la partition

Il te reste simplement à noter le sdxy sur la ligne LABEL="Mint", celui sur la ligne LABEL="Mint_Home" et celui sur la ligne "TYPE=swap".

Edit: Même résultat avec Mint Debian, toujours pas de dual boot... :(

Pourtant j'avais bien vu une option "Install Grub" cochée pendant l'install!

Dans ce cas Grub a certainement été installé mais la question qui se pose c'est : où ?

Je n'ai aucune expérience en matière de multiboot sur plusieurs disques durs mais peut-être que Grub n'a pas été installé sur le bon disque dur. Si sda désigne ton disque dur principal, celui sur lequel est installé Windows, mais que Grub a été installé sur sdb, le 2nd disque dur, il est peut-être normal que tu n'accèdes pas au menu de Grub au démarrage du système.

Encore une fois n'acceptes pas l'installation automatique de Grub, cliques sur l'option qui te permet de l'installer manuellement et indique à l'installateur où tu souhaites que Grub soit installé.

Si ton disque dur principal est nommé sda par l'installateur Linux tapes : /dev/sda.

Share this post


Link to post
Share on other sites

Dans ce cas Grub a certainement été installé mais la question qui se pose c'est : où ?

Ton message m'a enfin mis sur la voie! Grub était installé sur le disque sur lequel j'avais installé Linux! Or, mon BIOS était configuré pour booter sur le disque Windows. D'où l'absence de Grub au démarrage!

Il m'a juste suffi de changer l'ordre de boot des disques et choisir celui de Linux en premier pour résoudre mon problème! Et le dual boot marche bien! :D

Merci Manervi, et merci aux autres d'avoir aussi essayé de m'aider. :jap:

Share this post


Link to post
Share on other sites

1/ Linux a effacé tout le contenu de mon disque physique. Au lieu de réduire l'espace de la partition existante, il a laissé le reste de l'espace en Unallocated space. Je ne comprends pas pourquoi (même si je sais que c'est irréversible...)

Testdisk permet de retrouver les partitions supprimées de la table des partitions

L'installateur Linux devrait identifier les partitions avec une dénomination du type sdxy. Le s indique que la partition est sur un dd sata (si c'était un disque ide le s serait remplacé par un h), le x correspond au périphérique de stockage (dd interne, dd externe, clé usb) relié à ta cm (a = 1er, b = 2e, etc.) et le y correspond au n° de la partition.

Depuis le noyau 2.6.20 les deux utilisent la désignation sd* il me semble, les disques IDE étant gérés par le même drivers que les disques SATA (sauf si l'option est désactivée dans le kernel)

Share this post


Link to post
Share on other sites

×
×
  • Create New...