Jump to content

[RESOLU] Perte clavier et souris - Ubuntu 11.10


Carpe_Diem

Recommended Posts

Bonjour,

merci au dual boot Win7/Ubuntu qui me permet de m’adresser à vous pour un conseil de dépannage.

Mon clavier et ma souris Bluetooth Logitech MX5500 ne sont plus reconnus au démarrage depuis la 11.10 que je viens d'installer en mode automatique de mise à jour ce matin.

Comme en mode de démarrage normal, j'arrive uniquement sur la mire de connexion (saisie du mot de passe), je suis parti en mode dépannage puis connexion root. le tout pour tenter de faire cette manip.

Inutile puisque Ubuntu me dit : ne modifier pas, cela ne sert à rien, les modifications seront écrasées au redémarrage.

J'ai essayé de bricoler quelques trucs et nada, sinon que maintenant, même en mode dépannage, je n'ai accès ni au clavier ni souris.

Auriez-vous une solution détaillée svp ? J'ai du faire des co____ries avec mes essais et je n'y connaît rien en "vi".

Merci de votre aide :chinois:

PS : j'ai le CD d'Ubuntu 11.04 mais je crains qu'avec un démarrage sous Win7, il vienne m'écraser mon Win7. En effet, j'ai Win7 sur un HDD et Ubuntu sur un autre HDD.

Link to post
Share on other sites

Salut,

pourquoi les modifs ne seraient pas prises en compte au prochain démarrage ?

tu as bien édité en root ?

Pour vi pour enregistrer "echap" + :w + "entrer"

Pour enregistrer & quitter "echap" + :wq + "entrer".

j'ai pas compris le PS mais booter sur le cd n'écrase rien du tout et même si tu installes ubuntu, il y a grub qui laisse ton windows tranquille.

EDIT : tu fais comment la manip ? via un SSH ? via un clavier "physique " ? en bootant sur le cd 11.04 ?

Link to post
Share on other sites

Merci de ta réponse Treflemard

Pour mieux répondre à tes questions, j'ai refait la manip.

J'ai dans le même PC, 2 HDD système distincts : un pour Win7 et un pour Ubuntu. Le dual boot est très bien géré avec

- Ubuntu en mode normal

- Ubuntu en mode dépannage

- Ubuntu ancienne version

- memtest

- Win7

Donc pas besoin de connexion SSH ou autre.

Pour la manip via un clavier physique bluetooth :

- choix Ubuntu en mode dépannage

- affichage du " Recovery menu (limited read only menu) "

- je fais le choix 4 : " root -- Passer sur une console admin "

- je fais OK et j'ai alors le prompt : root@<mon nom d'ordi Ubuntu>-System-Product-name : ~#

- je tente un su - sa qui n'est pas reconnu puis un su - root qui me donne le même prompt

- je lance la commande vi /lib/udev/rules.d/62-bluez-hid2hci.rules

- là, en haut de la fenêtre de la console : "Do not edit this file, it will be overwritten on update"

J'ai arrêté là et suis sorti du vi via un :quit.

Grrr... pas moyen de sortir de la console.... ===> j'ai trouvé "ALT F7" sur le Net semble t'il.

J'ai reseté (et non pas redémarré) et me revoici.

En espérant avoir été plus explicite.

Tu avais tout à fait raison, ma première présentation faite de mémoire manquait de clarté.

Merci pour ton rappel sur :w et :wq ... je vais reprendre mon pense-bête "VI" du bureau pour le ramener à la maison.

NB : j'ai retrouvé clavier et souris en mode dépannage a priori en bootant d'abord sur Ubuntu en mode normal. Puis je suis revenu en mode dépannage et ce fut OK....ouf !

Link to post
Share on other sites

de rien,

quand je parlais de SSH c'était pour lancer ubuntu en mode normal et se connecter à distance (pc à côté) via SSH pour modifier le fichier /lib/udev/rules.d/62-bluez-hid2hci.rules

Je n'ai pas de clavier blueetooth mais je viens d'essayer de faire la même manip que toi et je n'ai pas le message "Do not edit this file, it will be overwritten on update". Je suis encore en 11.04. Je n'ai pas encore fait la M.A.J.

une fois que tu as çà : root@<mon nom d'ordi Ubuntu>-System-Product-name : ~#

j'essayerai direct vi /lib/udev/rules.d/62-bluez-hid2hci.rules

puis de corriger comme expliqué sur ton lien.

puis :wq et de reboot.

Je me demande si la phrase "Do not edit this file, it will be overwritten on update" ne veut pas dire que ta modif sera supprimé à la prochaine mise à jour du système si il concerne ce fichier ... Donc je tenterai de faire la modif et de voir ce qui se passe.

D'ailleurs tu as bien mis ubuntu à jour ? ( toutes les mises à jour sorties depuis la 11.10 ont été installées) ?

Link to post
Share on other sites

Ubuntu est en version initiale 11.10 sans packages corectifs. Etant bloqué sur le mot de passe que je ne peux pas saisir, je n'ai pas pu lancer les mises à jour post 11.10.

J'ai donc refait la manip : root@<mon nom d'ordi Ubuntu>-System-Product-name : ~# vi /lib/udev/rules.d/62-bluez-hid2hci.rules

et j'ai terminé avec

- :wq ===> E45 : "readonly option is set" add ! to override. Ce que je m'empresse de faire (on retrouve la syntaxe unix)

- :wp! ===> E212 : " can't open file for writing "

- je fais mon quit! puis un exit (les commandes alt F7 ou CTRL Alt F7 ne fonctionnaient pas).

Je me retrouve sur le menu initial du menu dépannage... ouf !

Je fais le choix 1 "reprendre le démarrage normal".

Retour sur la mire de saisie du mot de passe et ====> pas de clavier avec, sur le petit écran du clavier "pas de connexion".

Link to post
Share on other sites

1/ çà parait bizare car moi j'arrive à éditer mes fichiers...

essaye avec sudo devant la commande soit: sudo vi /lib/udev/..... etc ...

2/ tu n'as pas un clavier filaire ? Pour faire la manip sous ubuntu normal.

3/ tu lances le cd live (qui te permet de faire marcher ton clavier), une fois le tout lancé tu montes la partition depuis le live CD

Tu montes donc la partition /

çà doit être via ces commandes:

sudo mkdir /media/partition_systeme

sudo mount /dev/sdax /media/partition_systeme

ou a est la lettre du disque et x est le numéro de partition

et après tu devrais pouvoir éditer le fichier 62-bluez etc ....

Link to post
Share on other sites

Je viens de vérifier, le fichier n'a pas été modifié après toutes mes manip.

Oui, moi aussi je trouve bizarre que je ne puisse pas modifier un fichier alors que tu peux.

J'ai essayé la commande Edit dessus et là aussi c'est refusé mais pour d'autres raisons que je n'ai pas relevées.

Je pense que le reboot ayant été incomplet (pas d'ouverture de session arrivant sur le bureau sans mon mot de passe) suite à l'install auto de la 11.10, Ubuntu n'est pas totalement finalisé.

J'ai aussi lancé les options du menu de dépannage, sans succès.

Bref, depuis 8h00 ce matin, ça me lasse. Je vais essayer de trouver un clavier filaire demain.

Edit : j'ai essayé le sudo et idem.

J'ai relevé les droits, ça peut donner une piste :

- RW - R - - R - - 1 root root 1356 2011/10/14

Il y a quand même un truc que je ne comprends pas : pourquoi en mode dépannage mon clavier est fonctionnel alors que je n'ai pas le CD d'install inséré comme conseillé dans le topic de dépannage en premier post ? :zarb:

Link to post
Share on other sites

Salut,

Ubuntu n'a pas besoin de redémarrer normalement pour s'installer. L'installation est terminée au "reboot".

je ne comprend pas non plus pourquoi ton clavier marche en mode dépannage. Peut être que çà "active" par défaut tout ...

j'ai mis à jour mon portable et j'ai le même problème que toi impossible d'éditer ce foutu fichier ... même problème de permissions ... j'ai essayé différents trucs rien à faire ...

le meiux est soit le clavier filaire soit le boot sur live CD / live USB si tu es motivé ..., montage de partitions & edit ..

Link to post
Share on other sites

Depuis mon dernier message j'ai parcouru le site ubuntu.fr et on en revient à la solution présentée en premier message.... sauf pour les droits où je n'ai rien trouvé.

Sur mon fichier sous rules.de, si je traduis les permissions -RW-R--R-- , j'obtiens :

le premier - : c'est un fichier

RW- : droits du proprio pour Read, Write et pas d'execute

R-- : droits des groupes définis : Read mais pas Write ni execute

R-- : idem pour les autres utilisateurs

Donc, pas besoin de chmod 777 si j'ai tout compris car je suis le seul propriétaire à moins que ce soit root le proprio ???

En tout cas merci de ton aide et bravo pour avoir tenter la 11.10 sur ton portable. Mais je peux pas t'aider !

Je viens de télécharger la version 11.10, reste à graver et à réinstaller en espérant que ça marche sans casser mon windows. J'ai quelques appréhensions et préfèrerai résoudre autrement.

Link to post
Share on other sites

oui, l'user root et (le group root) sont les proprios du fichiers comme expliqué ci-dessous. (je suis pas tout à fait sur pour le groupe root)

- RW - R - - R - - 1 root root 1356 2011/10/14

donc logiquement en tant que root on devrait pouvoir l'éditer. mais non ... je me demande si c'est pas le disque entier qui est en lecture seule mais alors dans ce cas, il n'y a plus aucun intérêt à avoir le mode dépannage si l'on ne peut rien faire ...

je pense pas que tu aies besoin de réinstaller. Car à mon avis çà sera pareil... il faut arriver à éditer ce fichier. Soit via clavier physique soit en bootant sur le live CD / USB et en montant les partitions puis en éditant.

ubuntu fait attention avec windows, je n'ai jamais eu de soucis dans ce sens là. ( ubuntu après windows)

Link to post
Share on other sites

Bon, avant de jeter tous mes HDD par la fenêtre, j'ai chargé la 11.10, graver l'iso et tenter diverses approches :

- install sous Win7 : l'installeur Ubuntu ne voit pas mon disque qui lui est dédié

- install via F8 au lancement pour choisir le disque de boot, choix du lecteur CD ===> ouverture de l'installeur Ubuntu et là, pas de souris ni clavier.

- install en modifiant le Bios pour démarrer le CD en premier (cf.mon sujet de 08/2010) ===> ouverture de l'installeur Ubuntu et là, pas de souris ni clavier.

Bref, KO sur toute la ligne depuis ce matin avec au bilan depuis 1,5 an :

10.04 : clavier et souris KO

10.10 : OK

11.10 : KO.

Bonne nuit à tous.

Link to post
Share on other sites

Suite :

- achat clavier filaire à 20€ (acheter au + vite quoi).

- lancement Ubuntu ===> clavier filaire OK en USB et KO en PS2, mais j'ouvre la session.

- après recherche, je trouve un truc Bluetooth dans le menu Ubuntu ===> rien n'est détecté

- je charge usbwho ou whousb (je ne sais plus) et il découvre mes 2 périphériques BT et les identifie parfaitement

- mais Ubuntu ne veut presque rien savoir... mouvement brusque et je bouge la souris BT ===> message "voulez vous autoriser la souris Bluetooth ...etc..."

- je tente en vain de dire oui : pas moyen de surligner "Accepter" dans le message... je rage. Mais clavier BT toujours KO.

- mise à jour des paquets synaptics

- clavier souris Bluetooth restent KO

- tentative de modif du fichier : toujours les mêmes messages : "Non, le fichier tu ne modifieras pas" !

Suite de l'épisode demain.

Link to post
Share on other sites

Je n'ai pas poursuivi, j'ai fait une pause.

Je vais profiter de ce long WE pour retenter l'opération et réussir à répondre "Accepter" à ce message apparu par hasard.

Sinon, je tenterais peut-être une réinstall complète à partir du boot + F8 (et non pas sous Win7 qui ne voit pas mon HDD dédié Nunux).

En passant par :pleure::mad2::eeek2::zarb: pour finir par :yes: ?

Link to post
Share on other sites

Je te remercie de ton aide :chinois:

Hélas, après réinstall complète (F8 au boot et choix 1 "désinstaller et réinstaller") sur mon HDD dédié, suivi des mises à jour (165 paquets quand même), install des pilotes graphiques AMD, vérif dans différents menus dont Bluetooth (vu actif), c'est toujours KO.

J'ai réussi à avoir de nouveau le message d'autorisation pour la souris et j'ai réussi à cliquer sur "Accepter". mais la souris n'en était pas + active pour autant.

Le clavier BT est KO aussi.

Pas de pilote du MX-5500 en Linux.

Bref, une install propre mais sans succès pour le BT.

NB : dans le menu d'install de cette 11.10, il y a l'option de désinstallation. Que fais-je :reflechis: ?

Link to post
Share on other sites

Alors, passage en mode terminal.

Edition du fichier directement avec la commande (sans se mettre sous le répertoire concerné) sudo gedit /lib/udev/rules.d/62-bluez-hid2hci.rules

Modif du "hiddev*" en "hidraw*" suivi d'un Ctrl+S.

Malgré l'avertissement en haut de fichier (écrasement si update) et une série d'alerte dans le terminal après la sauvegarde du fichier "GTK Warning : /root/.local/share/recently-used.x bel" n'existe pas, j'ai redémarré le PC sur Ubuntu en enlevant le clavier USB de secours juste avant le Bip du Bios ===> miracle, souris et clavier BT MX 5500 fonctionnels.

En prime, le pavé numérique est enfin activé par défaut.

A ton intention treflemard : mille :bravo: et plein de remerciements. :yes:

Edit : écrit depuis Ubuntu.

Link to post
Share on other sites

Salut,

beh de rien.

Si jamais tu as un autre soucis avec ubuntu n'hésite pas ;)

Le message d'avertissement est en fait un commentaire donc il doit pouvoir être outrepasser ... Par contre, à mon avis, selon les MA.J. tu risques de devoir refaire le même cirque ...

Link to post
Share on other sites

Salut,

Autre solution qui marche peut être. (je m'en suis aperçu en galérant cet aprèm avec un vieux pc sous ubuntu ...)

Booter en mode dépannage,

choisir remount remount/read/write and mount all other file systems.

puis root ( pour éditer les fichiers ) ou netroot ( pour éditer les fichiers & avoir le réseau )

puis faire la manip expliquée plus haut.

Link to post
Share on other sites

Salut Treflemard,

j'ai essayé cette manip (je n'ai pas tout détaillé dans mes posts), et c'est KO. Résultat idem : refus de modif, non prise en compte.

Pour les intéressés, NoSquint fonctionne aussi bien que sous Windows.

Note : le pavé numérique n'est plus actif à l'ouverture. J'avais tenté le numlockx, mais ça n'avait pas marché avec ma 11.04. Je n'ai pas ré-essayé avec cette 11.10.

Ce qui me gêne maintenant, c'est l'absence de pare-feu.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...