Jump to content

Archived

This topic is now archived and is closed to further replies.

amidamariu

Changement de dd

Recommended Posts

Bonjour,

J'aurai besoin d'aide pour cloner un disque dur, j'ai fait plusieurs tentative via des logiciel sous windows sans succès... sous linux j'ai un peur de faire n'importe quoi avec la commande dd, qui à l'air de vraiment se compliquer quand le disque de destination est plus petit. 

Voila ma configuration :

un raptor de 36go : windows et le mbr

un dd 80go IDE : linux ( / , swap et un vide de 14go)

Mon disque IDE est d'une lenteur folle il est en fin de vie... j'ai sous la main un dd de 80go en sata.

Gparted me donne 74go51 pour le sata, et 74go53 pour l'IDE...

Ma question est simple, comment utiliser au mieux la commande dd (ou autre) dans mon cas.

Merci

Amidamariu.

Share this post


Link to post
Share on other sites

Merci, dans mes recherches, je suis bien tombé sur ces liens, mais dans les deux cas : "Si vous copiez sda vers sdb, un disque entier avec une seule partition, sdb étant plus petit que sda" me gène, car c'est pas mon cas. 

Share this post


Link to post
Share on other sites

Coucou !

Vu que tu dis que tu as un vide de 14 Go, pourquoi ne pas faire des dd que des partitions contenant des données ?

Share this post


Link to post
Share on other sites

Bonjour à tous

j'ai donc essayé de transférer mon / via

 sudo dd if=/dev/sda1 of=/dev/sdc1 bs=4096 conv=notrunc,noerror 

Ce fut... très long (40go à partir d'un DD mourant), le résultat a été le suivant : une partition / prenant tout sdc, j'ai donc voulu réduire la partition pour pouvoir faire la même opération avec le swap mais impossible (message d'erreur très court et pas clair dans Gparted).

Depuis mon PC ne démarre plus si je laisse brancher le sdc, freeze sur un écran mauve avant le log.

Le branchement à chaud du sata ne marchant pas... je retourne sous windows pour formater mon sdc.

Si quelqu'un a une idée. 

Share this post


Link to post
Share on other sites

tu avais créé /sdc1 de la bonne taille avant ?

sinon c'est pas plus simple de réinstaller linux sur le nouveau 80 GO et après de copier les fichiers importants ?

La partition swap est normalement vide donc çà devrait être instantané. c'est juste une partition servant de cache.

Share this post


Link to post
Share on other sites

Salut

Je te conseille acronis disk director suite.

Ca te donne un iso bootable.

Tu demarre dessus, tu rentre dans le soft, et tu demande cloner un disque.

Si tu garde la meme capacité, dans un 2eme temops, tu peux etendre ta partition sur le new dd sans perdre tes données et donc recuperer tout le disque

Share this post


Link to post
Share on other sites

Je suis un C**

Mon pc a finalement démarré avec le nouveau disque dur de branché (j'ai démarré j'avais oublié qu'il était branché et ca a bien démarrer)

J'ouvre Gparted et je sais pas comment j'ai fait j'ai supprimer la partition de mon raptor (windows + mbr) ...

c'est récupérable ? j'ai juste supprimer la partition, aucun formatage...

Share this post


Link to post
Share on other sites

J'ai trouvé testdisk, il voit bien la partition perdue, il me liste mes fichiers.... donc en recréant la table des partitions ca devrait être ok.

Mais comment vérifier que mon mbr est ok?

Share this post


Link to post
Share on other sites

Merci pour ta reponse.

récupération de la partition via testdisk => OK

réinstallation de grub via ton ton lien => OK

redémarrage => "error no such device 987897-.... "

grub rescue>

:'(

Share this post


Link to post
Share on other sites

tu as bien installé grub/le mrb sur le bon disque ?

tu as essayé en changeant dans le bios le disque "bootant" en 1er ?

sinon, désolé plus aucune idée. Je serais toi je réinstallerais linux à mon avis çà te prendra moins de temps ...

Share this post


Link to post
Share on other sites

Alors je viens tout juste de régler le problème.

Effectivement tu as raison je pense, le problème venait du disque d'installation.

J'avais utilisé le mode automatique de boot-repair et je pense qu'il avait configuré le boot sur la copie de "/" sur le dd récent, car je n'avais pas le même message avec le 80go sata branché.

Je l'ai débranché => super grub disk pour booter => nouveau boot-repair en automatique => depuis tout remarche.

Je lance une nouvelle copie de / mais en créant la partition auparavant pour qu'elle ne prenne pas tout le disque => réponse dans 4h.

Share this post


Link to post
Share on other sites

×
×
  • Create New...