Jump to content

VLC et les films en haute def


Recommended Posts

Bonjour,

Sur un ordinateur portable récent, j'ai voulu lire des films en haute définition (format MKV 1080p ou 720p).

Mon reflexe habituel = utiliser VLC 1.0.6 sous mon Ubuntu 10.04.1 LTS.

Sauf que cela saccadait complétement (les pilotes graphiques propriétaires Nvidia sont bien en place).

Je suis passé à Ubuntu 10.10 (pour avoir VLC 1.1.5), et le résultat n'est guerre meileur.

Qu'utilisez-vous pour lire vos médias haute définition ?

On m'a parlé de XBMC, je ne sais pas sur quel moteur il repose.

Merci

Benjamin

Link to comment
Share on other sites

vlc.

De rien.

:D

Sinon : sur VLC: Menu " Outils " -> Lecture et Codecs -> cocher " utiliser l'accélération matérielle du GPU "

Sinon ( bis ) : Portable ? CG ? CPU ? Est ce que l'accélération matérielle est reconnue ? ( le machin de type glxinfo | grep render ou un truc comme ça :D )

Sinon ( ter ) : sur VLC: Menu " Outils " -> Messages -> niveau de verbosité à 3 et regarde si ya rien qui te choque.

Link to comment
Share on other sites

Pour que la carte NVIDIA et les pilotes accèlerent la lecture video il faut aussi s'assurer d'avoir le VDPAU, mais normalement ça devrait être le cas. Avec ça sur du matos très light la HD passe sans probleme, mon mediacenter a un cpu atom, une carte video nvidia 9600, et ça marche très bien. Je comprend pas pourquoi il faudrait plus...

Link to comment
Share on other sites

Pour que la carte NVIDIA et les pilotes accèlerent la lecture video il faut aussi s'assurer d'avoir le VDPAU, mais normalement ça devrait être le cas. Avec ça sur du matos très light la HD passe sans probleme, mon mediacenter a un cpu atom, une carte video nvidia 9600, et ça marche très bien. Je comprend pas pourquoi il faudrait plus...

Merci pour vos réponses.

Bon, "très light", c'est relatif, sur ma machine, j'ai une carte graphique intégrée ATI X1200 à mémoire partagée (entre 64megs et 256), et c'est pas la peine de vouloir voir un 720p.

Sinon, j'ai fait les modifications préconisées sur VLC, sans succès.

Pour conclure, j'ai décidé d'employer SMPlayer + VDPau.

A bientôt - merci.

Benjamin

Link to comment
Share on other sites

  • 2 weeks later...

Benjamin,

Sur des machines avec un petit CPU (je pense au linutop et autre PC très basse consommation), VLC est le moins consommateur de ressources.

Maintenant on ne fait pas de miracle pour la HD...

Je suis passé à Ubuntu 10.10 (pour avoir VLC 1.1.5), et le résultat n'est guerre meileur.
Sinon avec Ubuntu 10.10 c'est VLC 1.1.4

La version 1.1.7 sera présente dans la 11.04

Link to comment
Share on other sites

  • 3 weeks later...

Le problème c'est que l'accélération matérielle ne marche pas avec ta carte ATI sous Linux.

Il faut avoir les derniers pilotes ATI/AMD proprios et avoir une carte des séries Radeon 4000 ou 5000.

Quel est ton processeur ?

Link to comment
Share on other sites

Le problème c'est que l'accélération matérielle ne marche pas avec ta carte ATI sous Linux.

Il faut avoir les derniers pilotes ATI/AMD proprios et avoir une carte des séries Radeon 4000 ou 5000.

Quel est ton processeur ?

Rectification : ça marche, mais pas tout le temps, et souvent mal. La faute à AMD qui ne documentait pas l'API XvBA du pilote Catalyst pour linux, et laissait le soin à une société externe de proposer un wrapper libva closed-source (VA-API étant le "langage" retenu par Intel, et adaptable pour d'autres langages). Comme les deux composants n'évoluent pas à la même vitesse, souvent c'est cassé.

AMD vient seulement de documenter XvBA avec la sortie de la dernière version, un peu tard serais-je tenté de dire. Et surtout, reste à savoir si VLC&Co vont chercher à l'implémenter, ou si un groupe de développeurs ne va pas simplement recréer un wrapper libre cette fois qui se baserait sur les deux specs ouvertes. Avec à la clé des performances moindres qu'un appel direct, comme pour VDPAU.

Bref, AMD a bien foiré sur le coup. Pour ma part, j'aurais préféré pouvoir directement utiliser l'UVD avec le pilote libre, mais c'est malheureusement impossible, la faute à qui ? DRM power...

Link to comment
Share on other sites

C'est ce qui m'a fait choisir une carte nvidia lorsque je suis passé sous ubuntu alors que je n'avais que des cartes ATI jusqu'alors.

On a beau râler sur le fait que nvidia n'ouvre pas les specs mais au moins c'est fonctionnel. Je préférerai libre et fonctionnel mais bon ...

Link to comment
Share on other sites

Nvidia est aussi plus prompt à supporter les nouvelles versions du noyal Linux. Pour AMD, il peut se passer plusieurs mois (et entre temps, une autre nouvelle version est sortie...). Les utilisateurs de rolling(release (arch&co) apprécient, à défaut d'avoir un pilote libre aussi stable et fonctionnel.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...