Jump to content

Empathy, Pidgin... connexion impossible


Recommended Posts

Bonjour,

Je n'arrive plus à me connecter à mes comptes Gtakl, Jabber et MSN, que ce soit avec Empathy ou Pidgin. J'ai essayé pas mal de configuration, j'arrive uniquement à me connecter à MSN lorsque je coche la case "Utiliser le protocle HTTP" et j'arrive à me connecter à Jabber si je passe par le port 443. Cela me fait donc penser à un soucis de firewall... chose que je n'ai pas o_O... à moins qu'il se installé tout seul et se soit bien caché.

J'ai essayé pas mal de configuration différentes pour mes comptes, mais rien n'y fait.

À noter que j'ai récemment mis à jour mon ordinateur portable avec la 10.04 64 bits et que tout fonctionnait très bien quand j'étais en 9.10 (je ne dis pas pour autant que ça vient de la 10.04 ^^). Je suis connecté en wifi sur une connexion perso.

Si quelqu'un a une idée pour résoudre mon problème.

Merci de votre aide.

p.s: j'ai posté le même sujet sur le forum ubuntu, mais après une semaine et près de 100 vues, je n'ai eu aucune réponse :(. En espérant que j'en ai plus ici ;)

Link to post
Share on other sites

Une réponse ! Merci ;)

Malheureusement, j'ai du partir de chez moi sans mon ordinateur portable... Je ne pourrai maintenant voir pour ce problème que samedi prochain.

Le serveur Jabber que j'utilise est celui de l'APINC (im.apinc.org). Je testerai donc le ping vers celui-ci.

Link to post
Share on other sites

C'est à un problème de ce genre que je pensais, mais le truc c'est que je ne crois pas avoir de pare-feu d'installé. J'ai essayé tout de même de le trouver, mais ne connaissant pas encore parfaitement Ubuntu, je n'ai peut-être pas cherché au bon endroit.

Le truc c'est qu'après l'install de la 10.04, j'ai exécuté un script de post installation (pas forcément la meilleure idée que j'ai eu...), j'ai pas regardé en détails ce qu'il faisait mais il ne me semble pas qu'il ait installé un pare-feu.

Link to post
Share on other sites

Salut,

J'ai enfin récupéré mon ordinateur portable !

J'ai fait le ping sur le serveur Jabber comme conseillé par lorinc, voilà le résultat :

PING im.apinc.org (80.248.214.47) 56(84) bytes of data.
From 192.168.0.11 icmp_seq=1 Destination Port Unreachable
From 192.168.0.11 icmp_seq=2 Destination Port Unreachable

Link to post
Share on other sites

iptables ! Voilà le nom du vilain qui me faisait des misères.

Merci Amour :dd:

J'ai commencé par rechercher comment "couper iptables" et je suis tombé sur cet email de la mailing list debian --> http://lists.debian.org/debian-user-french...2/msg00153.html

J'ai lancé toutes les commandes listées :

/sbin/iptables -t filter -F
/sbin/iptables -t nat -F
/sbin/iptables -t mangle -F
/sbin/iptables -t raw -F
/sbin/iptables -t filter -P INPUT ACCEPT
/sbin/iptables -t filter -P OUTPUT ACCEPT
/sbin/iptables -t filter -P FORWARD ACCEPT
/sbin/iptables -t nat -P PREROUTING ACCEPT
/sbin/iptables -t nat -P POSTROUTING ACCEPT
/sbin/iptables -t nat -P OUTPUT ACCEPT
/sbin/iptables -t mangle -P PREROUTING ACCEPT
/sbin/iptables -t mangle -P OUTPUT ACCEPT
/sbin/iptables -t mangle -P POSTROUTING ACCEPT
/sbin/iptables -t mangle -P FORWARD ACCEPT
/sbin/iptables -t mangle -P INPUT ACCEPT
/sbin/iptables -t raw -P OUTPUT ACCEPT
/sbin/iptables -t raw -P PREROUTING ACCEPT

Et pouf ça refonctionne ! Par contre j'aimerai bien savoir pourquoi iptables me faisait ça...

En tout cas, merci pour votre aide ;)

Link to post
Share on other sites

B'jour,

Il est fort probable qu'au prochain reboot les règles iptables se remettent en place.

Tu peux voir les règles en ligne de commande avec

sudo iptables -L -nv

Si tu ne trouves pas ce qui lance le firewall, tu peux mettre tes commandes dans /etc/rc.local

Sinon en front end firestarter est pas mal http://doc.ubuntu-fr.org/firestarter

Ca permet de manipuler les règles iptables, mais avec une souris :)

Edit: Depuis la 8.04 apparement c'est plutot ca -> http://doc.ubuntu-fr.org/ufw

Link to post
Share on other sites

Effectivement, j'ai crié victoire trop vite, ça ne fonctionne plus -_-

Voilà le résultat de la commande de bill_baroud :

$ sudo iptables -L -nv
Chain INPUT (policy ACCEPT 1094 packets, 492K bytes)
pkts bytes target	 prot opt in	 out	 source			   destination		 
  55  2916 blockcontrol_in  all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   state NEW mark match !0x14 

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target	 prot opt in	 out	 source			   destination		 
0	 0 blockcontrol_fw  all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   state NEW mark match !0x14 

Chain OUTPUT (policy ACCEPT 1147 packets, 127K bytes)
pkts bytes target	 prot opt in	 out	 source			   destination		 
 571 40064 blockcontrol_out  all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   state NEW mark match !0x14 

Chain blockcontrol_fw (1 references)
pkts bytes target	 prot opt in	 out	 source			   destination		 
0	 0 RETURN	 all  --  *	  *	   0.0.0.0/0			212.27.40.241	   
0	 0 RETURN	 all  --  *	  *	   0.0.0.0/0			212.27.40.240	   
0	 0 RETURN	 all  --  *	  *	   192.168.0.0/24	   192.168.0.0/24	  
0	 0 DROP	   all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   mark match 0xa 
0	 0 NFQUEUE	all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   NFQUEUE num 92

Chain blockcontrol_in (1 references)
pkts bytes target	 prot opt in	 out	 source			   destination		 
0	 0 RETURN	 all  --  *	  *	   192.168.0.0/24	   0.0.0.0/0		   
8   392 DROP	   all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   mark match 0xa 
3   180 RETURN	 all  --  lo	 *	   0.0.0.0/0			0.0.0.0/0		   
  44  2344 NFQUEUE	all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   NFQUEUE num 92

Chain blockcontrol_out (1 references)
pkts bytes target	 prot opt in	 out	 source			   destination		 
1	70 RETURN	 all  --  *	  *	   0.0.0.0/0			212.27.40.241	   
 364 23112 RETURN	 all  --  *	  *	   0.0.0.0/0			212.27.40.240	   
0	 0 RETURN	 all  --  *	  *	   0.0.0.0/0			192.168.0.0/24	  
  64  6093 REJECT	 all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   mark match 0xa reject-with icmp-port-unreachable 
3   180 RETURN	 all  --  *	  lo	  0.0.0.0/0			0.0.0.0/0		   
  11   660 RETURN	 tcp  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   tcp dpt:443 
  63  3780 RETURN	 tcp  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   tcp dpt:80 
  65  6169 NFQUEUE	all  --  *	  *	   0.0.0.0/0			0.0.0.0/0		   NFQUEUE num 92

Si je fais un

iptables --flush

, ça enlève bien les règles (et pidgin fonctionne), mais elles reviennent dès que je redémarre (et pidgin ne fonctionne plus). Qui est-ce qui remet les règles ??

Link to post
Share on other sites
Qui est-ce qui remet les règles ??

Telle est la question :)

A vue de nez, c'est ufw

Tu peux tenter de l'arrêter en ligne de commande avec

sudo /etc/init.d/ufw stop

Si le iptables -L -nv est plus propre, c'est que ca vient de la

J'ai pas de 10.04 sous la main, je suis sous Debian (s'pareil, mais en mieux :ouioui: ), néanmoins quelques astuces:

- pour désactiver du démarrage

sudo update-rc.d ufw remove

- pour désinstaller

sudo apt-get remove ufw

Et toujours -> http://doc.ubuntu-fr.org/

Bill

Link to post
Share on other sites
J'ai désinstallé ufw, mais après un reboot les règles sont toujours de retour >_>

Diantre !

Si le "iptables --flush" suffit, essaye

sudo echo "iptables --flush" >> /etc/rc.local

Ca exécutera le flush a chaque démarrage du système

Link to post
Share on other sites
Oui, cette solution devrait fonctionner, mais doit bien y avoir un moyen de trouver qui modifie les règles iptables, non ? (je veux vraiment essayer de comprendre mon système ^^)

Ouaip, c'est efficace, mais sale, comme rustine :ouioui:

Tu as bien exploré les menus du sytème ? (Administration, Préférence ...)

Il y a des trucs en rapport avec firewall/iptables/shorewall/netfilter/ufw, dans /etc/init.rd/ ?

Histoire de trouver un indice sur le binaire, et du coup le paquet

Link to post
Share on other sites

Non rien trouvé...

Je te copie/colle le listing de /etc/init.d au cas ou...

acpid@			bootlogd*	   grub-common*		network-interface@		   pulseaudio*	  single*				umountroot*
acpi-support*	 brltty*		 halt*			   network-interface-security@  rc*			  skeleton			   unattended-upgrades*
alsa-mixer-save@  console-setup@  hostname@		   network-manager@			 rc.local*		speech-dispatcher*	 urandom*
anacron@		  cron@		   hwclock@			ondemand*					rcS*			 stop-bootlogd*		 winbind*
apparmor*		 cups*		   hwclock-save@	   pcmciautils*				 README		   stop-bootlogd-single*  wpa-ifupdown*
apport@		   dbus@		   irqbalance@		 plymouth@					reboot*		  udev@				  x11-common*
atd@			  dmesg@		  kerneloops*		 plymouth-log@				rsync*		   udev-finish@
avahi-daemon@	 dns-clean*	  killprocs*		  plymouth-splash@			 rsyslog@		 udevmonitor@
binfmt-support*   failsafe-x@	 lm-sensors*		 plymouth-stop@			   saned*		   udevtrigger@
blockcontrol*	 fancontrol*	 module-init-tools@  pppd-dns*					screen-cleanup*  umountfs*
bluetooth*		gdm@			networking*		 procps@					  sendsigs*		umountnfs.sh*

Link to post
Share on other sites

J'avais installé gufw (avant de désinstaller ufw). Mais ça n'avait rien donné. gufw me disait qu'il n'y avait aucune règle.

Ça m'énerve, y a toujours ce "quelque chose" qui remet les règles en place à chaque fois...

Link to post
Share on other sites

Je viens tout juste de remarquer que dès que je lançais Chromium, toutes les règles revenaient dans iptables ! Ça serait donc Chromium (en espérant que ce soit le seul...) qui me cause des soucis. Mais pourquoi ? Et comment faire pour lui dire d'arrêter de faire ça ! :p

edit : en fait non, ça remet aussi les règles si je lance Firefox (et d'autres logiciels ?)

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...