Jump to content

Archived

This topic is now archived and is closed to further replies.

styx2

disque dur et fdisk [Résolu]

Recommended Posts

Bonjour,

je n'ai pas réussi à trouver, alors j'espère que personne n'a déjà posté sur ce sujet...

J'ai monté une nouvelle configuration, et après l'installation de winXP, je ne peux plus démarrer une nouvelle install ou quoi que ce soit depuis le cd de windows... C'est assez genant. Le pc boot bien sur le cd mais reste sur un écran noir après le début du chargement.

En lançant fdisk, il me dit que mon disque a plus de 1024 cylindres et que ça peut poser des problemes à certains gestionnaires de boot...

Est-il possible de résoudre ce problème sur un disque de 80Go, et de conserver les données? et si oui, comment?

Merci

Schéma de partitionnement :

1 - winxp 40 Go ntfs

2 - partition étendue

Link to post
Share on other sites

Bon, après quelques essais, j'ai un autre pc, également en dual boot windows xp /linux, qui a les mêmes symptomes.

Un modérateur pourrait-il déplacer le sujet en section linux siouplait? Parce que je n'ai ces problèmes que lorsque les disques durs ont des partitions non reconnues par windows... mais par linux

Merci

Link to post
Share on other sites

Juste pour dire...

... sous Linux, fdisk n'est plus des masses utilisé (ou alors pour lister les partoches, avec un "fdisk -l"... mais je ne m'amuserais pas à toucher des partitions avec ce vieux machin)...

"cfdisk" est aussi léger, mais bénéficie d'une interface quand même beaucoup moins austère et prompte à faire buguer l'interface chaise clavier... :transpi:

Bon, par contre, les trucs tout clickodrome, pas vraiment ma chope de Chimay... donc, je n'en dirais pas grand chose...

Link to post
Share on other sites
Juste pour dire...

... sous Linux, fdisk n'est plus des masses utilisé (ou alors pour lister les partoches, avec un "fdisk -l"... mais je ne m'amuserais pas à toucher des partitions avec ce vieux machin)...

Si si c'est utilisé, genre dans le handbook gentoo (du coup j'utilise jamais cfdisk moi, et si je veux un truc graphique y'a gparted qui est mieux).

Link to post
Share on other sites

en fait si j'ai utilisé fdisk, c'était juste pour faire une vérification de la table des partitions, mon problème ne se situe pas au niveau du logiciel de partitionnement.

Par contre, je sais que windows ne reconnait pas le ext3 nativement (et je préfère comme ça d'ailleurs...), du coup le cd d'install de win ne reconnait pas la moitié de mon disque dur, mais au lieu de continuer avec la partition windows qu'il est censé reconnaitre, c'est l'écran noir... :smack:

Je rajoute que j'ai grub d'installé sur le mbr, qu'il fonctionne, et que la solution qui consiste à formater (la seule "solution" qui semble fonctionner) ne me convient pas, et enfin mon disque est un sata (réglé dans le bios pour etre "détecté" comme un ide).

Voila pour les détails.

Merci.

Link to post
Share on other sites

Et dans quel ordre sont tes partitions

(le résultat d'un fdisk -l nous aiderait)

mon hypothèse sous-jacente est que ouinouin aurait du mal avec une partition qui démarre loin dans le nombre de secteurs

question débile, en SATA il n'y a plus d'histoire de LBA/Large ? (j'ai bien un disque SATA mais la question ne s'est pas posée :smack: )

Link to post
Share on other sites

Peux-tu préciser les partitions de ton disque ?

Je dirai que c'est plutôt un problème Windows ou du disque dur.

J'ai eu le cas du portable de mon père qui ne lançait plus Windows (même en mettant Lilo ou Grub).

Un repartitionnement et reformatage de tout le disque a réglé le probème.

Sinon pour cfdisk, après une ou deux fois où il vous aura fait des trucs pas catholiques, vous retournerez à fdisk.

Link to post
Share on other sites
Peux-tu préciser les partitions de ton disque ?

fdisk -l

Disque /dev/sda: 160.0 Go, 160041885696 octets
255 heads, 63 sectors/track, 19457 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa57cd5e9

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1        1275    10241406    7  HPFS/NTFS
/dev/sda2            1276       19457   146046915    5  Extended
/dev/sda5            1276        1287       96358+  83  Linux
/dev/sda6            1288        1416     1028160   82  Linux swap / Solaris
/dev/sda7            3198        9571    51199123+   b  W95 FAT32
/dev/sda8            9572       15945    51199123+   b  W95 FAT32
/dev/sda9            1416        2684    10193179+  83  Linux
/dev/sda10           2685        3197     4120641   83  Linux
/dev/sda11          15946       18564    21037086    b  W95 FAT32
/dev/sda12          18565       19457     7172991   83  Linux

Je dirai que c'est plutôt un problème Windows ou du disque dur.

J'ai eu le cas du portable de mon père qui ne lançait plus Windows (même en mettant Lilo ou Grub).

Un repartitionnement et reformatage de tout le disque a réglé le probème.

C'est un probleme windows (parce qu'il ne reconnait pas linux), que j'ai avec 2 disques dont un neuf. Le cas est différent ici puisque le dual boot fonctionne très bien, mais pas la fonction console de démarrage, installation, ou quoi que ce soit qui demande de booter sur le cd de windows (que ce soit avec XP sp2 et XP pro)

Enfin, ça ne vient pas du cd car après 3 retours en magasin, ils n'ont rien trouvé d'anormal, et de toutes façons ça marche avec un disque dur sans linux.

PS : Quelqu'un pourrait-il me dire ce que signifient les '+' après la colonne 'Blocs' de fdisk?

Merci

Link to post
Share on other sites

Joli

j'imagine mal Ouinouin supporter plus de 4 ou 5 partitions, donc des sda12 pour lui ça n'a jamais du être prévu dans le code !!

tu as vraiment besoin de morceler comme ça ?

sous Linux je te recommanderait plutôt de faire des LVM

sous Windows ... bah euh des subst :-)

Link to post
Share on other sites
Si si c'est utilisé, genre dans le handbook gentoo (du coup j'utilise jamais cfdisk moi, et si je veux un truc graphique y'a gparted qui est mieux).

Ah oui, tiens... :kimouss: ... mea culpa : je pensais que même eux utilisaient cfdisk dans la doc...

... bon reste que je trouve fdisk un peu trop à l'ancienne (en tout cas, pour éditer), et j'ai eu tellement de galères avec gparted (il y a quelque temps, certes, je dois dire), que je me satisfais du juste milieu (style ncurse... même si je ne crois pas que c'en soit)...

Sinon, j'abonde dans le sens de Sandeman, pour le LVM... c'est quand même moult pratique (je m'en sers beaucoup sur mes vservers : au moins deux LV par vserver, un pour "/", un pour "/var"... et c'est très pratique)...

Link to post
Share on other sites

En fait j'ai listé les partitions de mon PC, mais sur la'autre qui pose aussi problème, il y a moins de partitions, du style :

/dev/sda1 - HPFS/NTFS

/dev/sda2 - Extended

/dev/sda5 - Linux (/boot)

/dev/sda6 - Linux swap / Solaris

/dev/sda7 - Linux (/)

/dev/sda8 - Linux (/home)

Pour le LVM, il va falloir que je m'y mette, mais l'inconnu pouvant faire peur, je n'ai pas encore osé m'en occuper...

Un test intéressant, essaie avec ton cd en débranchant ton disque dur pour voir si dans ce cas il arrive à démarrer.

OK, pas bète, je vais essayer ça, mais je me demande si il n'y a pas un autre message d'erreur si win ne trouve aucun disque dur.

Link to post
Share on other sites

Au vu de la dernière configuration, j'aurais tendance à dire que le problème est autre puisque la partoche NTFS est la première, elle est primaire et il n'y a que ce qui est derrière qui bouge...

Question idiote mais qui pourrait marcher... Est-ce que tu as essayé avec un autre cd de ouinouin ?

Link to post
Share on other sites
Question idiote mais qui pourrait marcher... Est-ce que tu as essayé avec un autre cd de ouinouin ?

Oui, avec 3 CD différents de XP édition familiale, et un de XP pro, tous fonctionnent si le disque dur est vierge ou ne contient que du ntfs.

Link to post
Share on other sites

C'est bizarre ...

Chez moi je n'ai aucun problème à booter un cd windows avec 3 disques dur dont 1 a au moins 6 ou 7 partitions (dont 1 seule NTFS), 1 autre 3 partitions linux, et un autre avec une partition FAT32.

Donc je ne vois pas pourquoi ton partitionnement serait en cause.

Link to post
Share on other sites
Pour mon portable (Win Xp Pro / OpenSUSE) aucun souci..

1) Win

2) swap

3) etendu

3.1) /

3.2) /home

... (etc)

essai comme ca

J'ai aussi une opensuse, mais je ne ne l'ai pas réinstallée après changement de carte mère. Les 2 pc concernés ont la même carte mère : gigabyte GA-P35 DS3R, est-ce que ça pourrait etre ça? Je ne me rappelle pas avoir eut ce problème avec le même disque dur sur mon ancienne config...

Pour le nouveau partitionnement, pourquoi pas, mais comme je ne veux pas tout réinstaller, ça attendra la sortie de la prochaine suse.

Link to post
Share on other sites

Faut pas tout réinstaller non plus.

Tu fais un backup de toutes les partitions.

Tu crées une nouvelle table de partoche.

Tu fais tes partoches come tu veux (apparemment tu veux essayer comme kran)

Tu n'oublies pas de mettre à jour le fstab et le menu.lst

Tu réinstalles grub

C'est fait.

Link to post
Share on other sites
Un test intéressant, essaie avec ton cd en débranchant ton disque dur pour voir si dans ce cas il arrive à démarrer.

Bon, après quelques temps sans toucher au pc, je me relance dans mes investigations :

j'ai débranché le HDD, et l'install de windows démarre (tout du moins les pilotes commencent à se charger).

Donc ça viendrait du disque dur, ou de la façon dont ma carte mère le gère...

Sauf que si le disque est vide, ça fonctionne... J'y comprend rien :eeek2:

Je vais sans doute bientot flasher mon bios, peut etre que ça aidera!?

Link to post
Share on other sites
C'est peut etre un bug de ta carte mere oui.

Dans ce cas la section hardware est plus appropriée :D

En fait j'en viens, c'est là que j'avais créé ce topic.

Mais comme les problemes n'apparaissent que quand linux est installé, j'ai été déplacé ici.

Sinon, pour le bug de la carte mère, c'est possible, mais j'ai ce problème avec 2 cartes (même chipset, même fabriquant : P35, Gigabyte). Un réglage dans le bios, peut etre, mais je ne vois pas lequel (j'en ai déjà essayé plusieurs). Sinon, je vais bientôt m'acheter un nouveau disque dur, alors je referai des essais dessus, pour essayer de trouver l'origine du souci.

Link to post
Share on other sites

×
×
  • Create New...