Jump to content

Archived

This topic is now archived and is closed to further replies.

MetalRaiden

Probable problème au niveau graphique

Recommended Posts

Bonjour tout le monde,

Pour vous expliquer mon problème , je suis désolé, je vous envoie le lien du topic où j'ai décris le problème car cela fait plusieurs fois que je poste pour ce problème(alors j'en ai marre de devoir réexpliquer, et ma version peut changer), sans avoir de solution, merci de votre compréhension :

http://www.playonlinux.com/fr/topic-1070-B...u_clavier_.html

Si vous pouviez m'aider, car je suis un mordu de jeux vidéos et j'ai beaucoup de mal à me passer d'un certain Jedi Academy :arrow:

Bien sûr j'attendrai le temps qu'il faut.

Je vous remercie d'avance mille fois ;)

Et vous souhaite une bonne soirée ! ;)

Share this post


Link to post
Share on other sites

C'est chaud ton truc !

Je dirais de faire rebelote avec ce que le gars t'as dit, à savoir virer envy, installer les drivers nvidia etc..... renommer ton xorg.conf pour qu'il soit recréé !

Donc, reprenons.

- virer le truc envy (je sais pas trop comment on fait)

- sudo aptitude install nvidia-glx-new

- sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.ancien

- reboot (là je suis pas sur que ce soit nécessaire, ça dépend si envy charge des bazars avec le noyau mais un confirmé t'en dira plus que moi :D)

- espérer que le serveur X démarre... Si ce n'est pas le cas faudra choper les logs (/var/log/Xorg.0.log et ~/.xsession-errors)

- sudo nvidia-xconfig --add-argb-glx-visuals -d 24 (là je sais pas ce que ça fait mais ça doit paramétrer ton serveur X)

Voilà j'espère que tu pourras déjà avancer avec ça...

My 2 cents...

EDIT: si envy est un blob faudra peut-etre réinstaller les paquets du serveur X pour etre sur d'avoir du bon !

Share this post


Link to post
Share on other sites

Euh, si je fais ça, soit enlever envy et installer les pilotes nvidia-glx-new, je risque encore de me retrouver sans interface graphique, car la dernière fois, j'ai réussi à tout remettre grace à Envy =/

J'ai un peu peur de ce qui pourrait se passer... :transpi:

Share this post


Link to post
Share on other sites

bah tu peux toujours récupérer une interface graphique : au pire, tu bouges le fichier xorg.conf (en faisant "sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.saved.20080207") et relancer X. Maintenant, X est capable de s'auto-configurer et devrait de donner une interface (pourri, mais elle devrait être là)

Après, normalement, kubunubut est suffisament pro-blob pour que les procédures d'install des drivers officiels ne soient pas trop dures. :D

Share this post


Link to post
Share on other sites

J'ai voulu tester cette méthode :

Problèmes sur les cartes NVidia geforce 7500 LE

1.

installez les drivers NVIDIA 1.0.9755

2.

tapez les commandes suivantes :

sudo nvidia-xconfig --add-argb-glx-visuals --damage-events --a --logo --nvagp=NVAGP

dpkg-reconfigure -phigh gdm

FIXME Une version des pilotes nvidia.run gérant cette carte est disponible sur le site officiel de nvidia http://www.nvidia.com/object/unix.html, la première version de ces pilotes est la 100.14.11. ATTENTION, les effets du bureau font toujours freezer les machines avec cette carte.

FIXME Certains possesseurs d'une carte graphique NVIDIA puce G72 (7300LE et 7500LE) et d'un chipset RS480 / 482, dont l'incompatibilité provoquait des freezes régulier doivent utiliser un patch (beta), sur le driver propriétaire 100.14.11: http://www.nvnews.net/vbulletin/showpost.p...p;postcount=100

Mais malheureusement, la commande donnée dans ce lien pour appliquer le patch : http://www.nvnews.net/vbulletin/showpost.p...p;postcount=100

Me sort un joli rien du tout, il ne se passe rien, j'ai essayé sans le "#" mais là il me sort :

sh: Can't open /path/to/NVIDIA-Linux-x86-100.14.11-pkg0.run

Qu'est ce que je peux faire pour que le patch s'applique et que j'installe correctement le pilote ? :D

EDIT : C'est bon, j'ai réussi, il y avait une erreur de syntaxe dans la commande, je vais essayer de l'installer, je verrais bien après :D

Share this post


Link to post
Share on other sites

Bon là, sérieusement, j'en peux plus ! :yes:

J'ai installé le pilote correctement, mais je n'ai plus aucune interface graphique encore une fois, je n'arrive plus à le faire revenir (je suis sur le livecd là)

Que puis je faire svp ? :D

Share this post


Link to post
Share on other sites

Ah oui effectivement avec /path/to/NVIDIA-Linux-x86-100.14.11-pkg0.run il y avait peu de chance que ça fonctionne :chinois:

Qu'est-ce que tu as comme erreur pour ton interface graphique ?

Poste nous les logs dans des codebox (je t'ai donné les endroits où les trouver ici plus haut)

Share this post


Link to post
Share on other sites

Zut, pardonnez moi, pendant que vous étiez, entrain de répondre, j'ai réussi à récupérer une interface graphique en remplacent dans le xorg dans la partie "device" :

driver "nvidia"

Par

driver "nv"

J'ai donc récupérer une interface graphique mais maintenant j'ai un célébre message d'erreur en lançant glxgears :

~$ glxgears

Xlib: extension "GLX" missing on display ":0.0".

Error: couldn't get an RGB, Double-buffered visual

Une idée :chinois:

D'avance, merci ! :mdr2:

EDIT : Je vous donne mon Xorg actuel pour vous aider :

# nvidia-xconfig: X configuration file generated by nvidia-xconfig

# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Jun 13 18:39:30 PDT 2007

# xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the xorg.conf manual page.

# (Type "man xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet

# InputDevice "stylus" "SendCoreEvents"

# InputDevice "cursor" "SendCoreEvents"

# InputDevice "eraser" "SendCoreEvents"

Identifier "Default Layout"

Screen "Default Screen" 0 0

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

EndSection

Section "Files"

EndSection

Section "Module"

Load "glx"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "fr"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ImPS/2"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "true"

EndSection

Section "InputDevice"

Identifier "stylus"

Driver "wacom"

Option "Device" "/dev/input/wacom"

Option "Type" "stylus"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Identifier "eraser"

Driver "wacom"

Option "Device" "/dev/input/wacom"

Option "Type" "eraser"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Identifier "cursor"

Driver "wacom"

Option "Device" "/dev/input/wacom"

Option "Type" "cursor"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "Monitor"

Identifier "Generic Monitor"

HorizSync 30.0 - 70.0

VertRefresh 50.0 - 160.0

Option "DPMS"

EndSection

Section "Device"

Identifier "nVidia Corporation G72 [GeForce 7500 LE]"

Driver "nv"

EndSection

Section "Screen"

Identifier "Default Screen"

Device "nVidia Corporation G72 [GeForce 7500 LE]"

Monitor "Generic Monitor"

DefaultDepth 24

Option "MetaModes" "1024x768"

Option "AddARGBGLXVisuals" "True"

SubSection "Display"

Depth 24

Modes "nvidia-auto-select"

EndSubSection

EndSection

Section "Extensions"

Option "Composite" "Enable"

EndSection

Share this post


Link to post
Share on other sites

C'est normal que tu n'as pas l'acceleration graphique avec le pilote NV

Quand tu lances l'interface avec l'option Driver "nvidia", quelle est l'erreur affichée ?

Share this post


Link to post
Share on other sites

Je vois que tu as un peu de mal :transpi:

Donc :

- remettre nvidia

- faire planter le bazar

- se logguer sur le tty (là ou ya pas d'interface graphique)

- cp ~/.xsession_errors ~/xsession_errors (attention à la différence, il manque un . au 2ème :duel1:)

- remettre nv

- dans ton dossier home tu auras le fichier xsession_errors

- poster le contenu DANS DES BALISES CODEBOX ET PAS CODE :pleure:

Share this post


Link to post
Share on other sites

Sarcasme pour moi même : "je me sens en vaine, je vais aller jouer au casino je crois" :transpi:

Alors voilà, je lance les deux commandes que tu m'as dit, mais même ça ne fonctionne, j'obtiens cette erreur :

cp: opérande du fichier cible manquant après `~/.xsession_errors'

Une autre idée ? :craint:

D'avance, merci :)

Share this post


Link to post
Share on other sites

On doit pas se comprendre entièrement toi et moi...

La commande exacte, complète et à faire en une seule fois et pas en multi morceau est la suivante :

cp ~/.xsession_errors ~/xsession_errors

Et là encore je préviens qu'il y a une différence entre les 2 noms.

cp c'est pour copier donc il faut un premier nom de fichier qui existe et un 2ème nom de fichier

Share this post


Link to post
Share on other sites

Vraiment navré :transpi:

Là, j'ai fais ce que tu m'as dit (mais vraiment là :D :

cp: ne peut évaluer `/home/administrateur/.xsession_errors': Aucun fichier ou répertoire de ce type

:reflechis:

Share this post


Link to post
Share on other sites

1 point pour toi sur ce coup là :D

Mais c'est bizarre quand meme... ton user est bien administrateur je suppose... Et je suppose aussi que tu ne fais pas ça à partir d'un livecd

Essaye de choper le log de X.org

cp /var/log/Xorg.0.log ~/logXorg.txt

Attention c'est très long donc utilise bien des balises codebox pour le poster ici :reflechis:

Ps: tu trouveras un fichier logXorg.txt dans ton dossier home

Share this post


Link to post
Share on other sites

Ce qui est très interessant c'est les dernières lignes...

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "MetaModes" "1024x768"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Il configure pour le screen 0 (normal) il enable les extentions (normal aussi) mais il n'arrive pas à loader le kernel nvidia...

Là par contre c'est mal :francais:

Après avoir jeté un coup d'oeil sur la doc ubuntu : http://doc.ubuntu-fr.org/nvidia

Ils disent qu'il faut bien les restricted modules de ton kernel... Donc

sudo apt-get install linux-restricted-modules-$(uname -r)

Si ça te dit que c'est déjà fait, alors tant mieux :ouioui:

Il peut y avoir aussi un soucis avec ta carte... Il faut faire ceci :

sudo nvidia-xconfig --add-argb-glx-visuals --damage-events --a --logo --nvagp=NVAGP
sudo dpkg-reconfigure -phigh gdm

Voilà j'espere que ça t'aidera :francais:

Share this post


Link to post
Share on other sites

Alors, c'est qu'on avance dans tout cela, lentement mais sûrement :transpi: (esperons)

donc, pour la commande ci :

sudo apt-get install linux-restricted-modules-$(uname -r)

Il me dit que c'est déjà installé, pour celle ci :

sudo nvidia-xconfig --add-argb-glx-visuals --damage-events --a --logo --nvagp=NVAGP

Tout se passe comme prévu. Et enfin, le meilleur pour la fin :

sudo dpkg-reconfigure -phigh gdm

Déjà, gdm n'était pas installé, ce que j'ai fais, et ensuite je réentre la commande, il me parle de configurer quelque chose, comme tu m'en à pas parlé, je savais pas trop quoi faire. Il m'a donc demandé, quel est mon gestionnaire graphique de session par défaut, je chois donc "kdm" avec entrée, et j'ai un joli message avec dedans

* Reloading GNOME Display Manager configuration... * Changes will take effect when all current X sessions have ended.

invoke-rc.d: initscript gdm, action "reload" failed

:transpi:

Que faire maintenant ? :transpi:

Share this post


Link to post
Share on other sites

Comme je savais pas si je devais faire planter le X avant je ne l'ai pas fais, mais ça me donne ça :

install /sbin/lrm-video nvidia

Not loading nvidia_new module; not used in /etc/X11/xorg.conf

Share this post


Link to post
Share on other sites

Pour ce que j'ai dit, j'ai oublié que tu utilisais kdm...

Je ne sais pas si c'est valable pour kdm aussi... Maintenant rien ne t'empeche d'utiliser gdm à la place de kdm...

Pour ce que t'a dit SlumSlaYer, tu dois remettre le truc nvidia dans xorg, quitter l'interface graphique (quoique tu dois pouvoir le faire en direct mais pas sûr, je préfère ne pas m'avancer) et lancer la commande donnée.

Share this post


Link to post
Share on other sites
Pour ce que t'a dit SlumSlaYer, tu dois remettre le truc nvidia dans xorg, quitter l'interface graphique (quoique tu dois pouvoir le faire en direct mais pas sûr, je préfère ne pas m'avancer) et lancer la commande donnée.

Peu importe que Xorg soit lancé ou pas :transpi: , c'est juste pour voir pourquoi le module ne se charge pas.

EDIT : Et pas besoin de remettre Driver "nvidia"

Share this post


Link to post
Share on other sites

×
×
  • Create New...