Jump to content

Archived

This topic is now archived and is closed to further replies.

reynald62600

linux sur mon portable

Recommended Posts

bonjour a tous

voila je voudrais beaucoup remplacer mon systeme par un ptit linux mais plusieur probleme

j'ai tester mandriva 2007.1 mais le wifi n'est pas detecter et j'ai bo checher je ne trouve pas comment on fais pour l'installer :D

apres ma carte graphique c'est une ati Xpress 1100 : il faut installer des pilotes ? pour la 3D ?

comment faire pour la vaille prolongé ?

voila la config

Acer Aspire 3104 WLMI

wifi :atheros AR5007EG

voila en fait peu importe la distrib que vous me proposer tant que ça merche

merci d'avance

Link to post
Share on other sites

Apparemment, certaines xpress 1100 sont en fait des radeon 200m... si c'est le cas, le driver libre est encore la solution la plus simple (si ton X.org de base est réglé pour utiliser le driver vesa générique, remplacer "vesa" par "radeon" dans la section "driver" de ton /etc/X11/xorg.conf devrait suffire... n'hésite pas à demander plus de détails au besoin... je commence à avoir l'habitude de ce driver)...

Si c'est bien une 200m, c'est censé marcher, mais avec les GPU de portable, les constructeurs (juste des assembleurs, en fait) font parfois (souvent) n'importe quoi en modifiant le bios et des choses du genre... à voir... de toute façon, ce ne sera probablement que pire avec l'immonde fglrx proprio...

... pour ta carte wifi, a priori, va voir du côté de madwifi avec son vilain blob proprio de régulation en userland... en attendant un dadwifi-openhal 100% libre sous linux (atheros a récemment déclaré qu'ils allaient abandonner d'eux même leur hal binaire... tant mieux)...

Pour la mise en veille prolongée, je ne connais pas assez mandriva pour ça... je laisse volontiers quelqu'un d'autre t'en dire plus...

Link to post
Share on other sites

Sur cette page :

http://doc.ubuntu-fr.org/materiel/liste_portables/acer

Une personne dit qu'elle a installé Ubuntu sur ton portable (enfun un de ses frères :craint: ) sans souci et que tout fonctionne. plus ou moins.

Le WiFi a été installé avec le driver Windows et ndiswrapper. Y a pas de raison que ça marche pas non plu sous Mandriva.

N'abandonne pas si près du but ! :-D

Link to post
Share on other sites

voila debian est installé :chinois:

et devinez quoi ? j'ai reussi !!!!!!!!!!!!!!!!!!!

mon wifi fonctionne ! ;) cooment j'ai fait ?

j'ai compillait ndiswrapper sans probleme :incline: puis ledriver windows XP et hop wlan0 activé !!!

je suis content :chinois:

maintenant je vais fouiller un peu pour mon driver ati !

a toute a l'heure

Link to post
Share on other sites

arf, c'est le point qui fait mal au fesses...

déjà, si jamais tu utilises un noyau optimisé multimédia (mm, rt ou autre), tu peux dire adieux au blob d'ATI. kmod refuse de compiler des drivers non GPL sur ces versions.

sinon, il faut que tu récupère les sources (ou au moins les headers) du noyau en train de tourner. tu l'obtiens par uname -r. une fois le package de sources installé, tu peux te lancer dans la compilation de l'afreux blob dégueux, ce qui ne devrait pas trop poser de problème (vérifier que /usr/src/linux -> /usr/src/$(uname -r) ).

Le plus délicat, c'est la conf de xorg. Regardes bien le log de xorg : /var/log/Xorg.0.log et notament les lignes qui commencent par EE ou par WW, s'il y a une erreur que tu ne comprends pas, remet un drivers sûr dans ton xorg.conf (vesa par ex) et vient poster le message d'erreur :vomi2:

Link to post
Share on other sites

Pour compiz, normalement, ça doit tourner avec le driver libre sur le genre de carte que tu as...

... je ne sais pas si le driver libre est utilisé par défaut, mais tu peux le vérifier en regardant si tu as bien

Driver "radeon"

dans la section Device de ton /etc/X11/xorg.conf... si tu as "vesa" à la place de "radeon", remplace juste ça...

Tu peux aussi faire un "glxinfo|grep direct", et s'il te met "yes", normalement, tu as l'accélération graphique avec le driver libre...

... par contre, ne jouant pas au PC, je ne saurais te dire pour AOE2... faudrait tester... mais s'il faut passer par le driver proprio, bonne chance...

Link to post
Share on other sites
merci je vais tester ça :byebye:

voila mon fichier sans rien toucher

Section "Device"
       Identifier      "ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]"
       Driver          "ati"
       BusID           "PCI:1:5:0"
EndSection

Section "Monitor"
       Identifier      "Écran générique"
       Option          "DPMS"
EndSection

Section "Screen"
       Identifier      "Default Screen"
       Device          "ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]"
       Monitor         "Écran générique"
       DefaultDepth    24
       SubSection "Display"
               Modes           "1280x800"
       EndSubSection
EndSection

Section "ServerLayout"
       Identifier      "Default Layout"
       Screen          "Default Screen"
       InputDevice     "Generic Keyboard"
       InputDevice     "Configured Mouse"
       InputDevice     "Synaptics Touchpad"
EndSection

Link to post
Share on other sites
tu devrais avori le DRI, là...

:chinois: ... logiquement, oui.

Pour être sur, que donne un : "glxinfo|grep direct" ?

Au pire, y rajouter :

Section "DRI"
	Group   "video"
	Mode	0666
EndSection

et s'assurer que tu fais bien partie du groupe video en regardant s'il apparaît dans un "groups" que tu lances en tant que ton utilisateur de X.org...

Link to post
Share on other sites

bon un peu de news aujourd'hui j'ai tenter d'installé les pilotes ati officiels :chinois:

j'ai du reinstaller X car je l'avais tuer lol

ensuite je me suis dit je vais installer le bureau en 3d donc j'ai installé avec succes compiz mais ça ne ma rien fait ! pourquoi ?

Link to post
Share on other sites

Je dis ça à tout hasard, mais ne pas oublier d'installer le paquet xserver-xgl.

Sur la bêta d'Ubuntu, Compiz est installé par défaut mais XGL pas, et chez moi ça ne fonctionnait pas sans ...

Qui plus est, plus besoin de bidouillage pour démarrer XGL, juste le paquet mentionné, relancer GDM, et c'est parti mon kiki.

Link to post
Share on other sites

bonjour a tous quelques news :

voila apres le plantage de X je l'ai reinstall et j'en ai profiter pour installer beryl

voila mon Xorg.conf

 Section "InputDevice"
	Identifier	  "Configured Mouse"
	Driver		  "mouse"
	Option		  "CorePointer"
	Option		  "Device"				"/dev/input/mice"
	Option		  "Protocol"			  "ImPS/2"
	Option		  "Emulate3Buttons"	   "true"
EndSection

Section "InputDevice"
	Identifier	  "Synaptics Touchpad"
	Driver		  "synaptics"
	Option		  "SendCoreEvents"		"true"
	Option		  "Device"				"/dev/psaux"
	Option		  "Protocol"			  "auto-dev"
	Option		  "HorizScrollDelta"	  "0"
EndSection

Section "Device"
	Identifier	  "ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]"
	Driver		  "ati"
	BusID		   "PCI:1:5:0"
	VideoRam		256000
	Option "XAANoOffscreenPixmaps" "true"
	Option "AddARGBGLXVisuals" "true"
	Option "AllowGLXWithComposite" "true"
EndSection

Section "Monitor"
	Identifier	  "Écran générique"
	Option		  "DPMS"
	HorizSync	   28-50
	VertRefresh	 43-75
EndSection

Section "Screen"
	Identifier	  "Default Screen"
	Device		  "ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]"
	Monitor		 "Écran générique"
	DefaultDepth	24
	SubSection "Display"
			Modes		   "1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Option		  "AIGLX"		 "true"
	Identifier	  "Default Layout"
	Screen		  "Default Screen"
	InputDevice	 "Generic Keyboard"
	InputDevice	 "Configured Mouse"
	InputDevice	 "Synaptics Touchpad"
EndSection

Section "DRI"
	Mode 0666
EndSection

Section "Extensions"
	Option "Composite" "Enable"
EndSection

beryl est bien installé mais voila quand je fait ça

reynald@:~$ beryl --test
**************************************************************
* Beryl system compatiblity check							*
**************************************************************

Detected xserver								: AIGLX

Checking Display :0.0 ...

Checking for XComposite extension			   : passed (v0.3)
Checking for XDamage extension				  : passed
Checking for RandR extension					: passed
Checking for XSync extension					: passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig				  : passed
Checking for GLX_EXT_texture_from_pixmap		: passed
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Checking for non power of two texture support   : failed

Support for non power of two textures missing

une solution ?

j'avance a petit pas :transpi:

edit : au fait

reynald@:~$ glxinfo|grep direct
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect

pourquoi ?

Link to post
Share on other sites

De toute évidence, tu n'as pas dri d'activé (or ça te permet justement d'avoir l'accélération graphique)...

a priori, tu n'as pas besoin de :

		VideoRam		256000
	Option "XAANoOffscreenPixmaps" "true"
	Option "AddARGBGLXVisuals" "true"
	Option "AllowGLXWithComposite" "true"

... d'ailleurs, une mauvaise valeur de VideoRAM (notamment) peut le faire planter direct... essaye en commentant ces options (rajoute un # devant)...

A priori, ne sont pas utiles non plus :

		Option		  "AIGLX"		 "true"

ni

Section "Extensions"
	Option "Composite" "Enable"
EndSection

Par contre, une section du genre :

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection

(surtout pour le dri, en fait) peut éventuellement être utile...

Link to post
Share on other sites

salut merci de vous pencher sur mon probleme

donc j'ai modifier mon xorg.conf

mais toujour le meme probleme

reynald@:~$ beryl --test
**************************************************************
* Beryl system compatiblity check                            *
**************************************************************

Detected xserver                                : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Checking for non power of two texture support   : failed

Support for non power of two textures missing
reynald@:~$ glxinfo|grep direct
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
reynald@:~$ 

quest ce que c'est de ça ????

merci d'avance

Link to post
Share on other sites

Mmm... étrange tout ça...

... tu as dit avoir dû réinstaller xorg après que ta tentative de fglrx l'ait cassé... comment t'y es-tu pris?

J'ai déjà vu des cas comme ça où, après installation de cette cochonnerie, certaines libs indispensables au dri avaient été écrasées par celles du driver proprio... la solution avait été, sous du Debian-like de faire quelque chose du genre :

apt-get install --reinstall xserver-xorg xserver-xorg-core

Sinon, autrement, peux-tu nous poster ton /var/log/X.org.log.0 sur un pastebin (ça fait un peu gros pour le mettre direct sur le fofo)...?

PS : question sûrement conne... tu redémarres-bien X.org entre tes modifications?

Link to post
Share on other sites

Si c'était le problème que j'ai déjà vu, un "dpkg-reconfigure"-like ne suffirait pas... il faudrait forcer une réinstallation, et pas juste une reconfiguration, car fglrx écrase des libs comme un sagouin...

... ceci dit, ton log m'inquiète plus que ça... cf ligne 554 :

(II) RADEON(0): Direct rendering broken on XPRESS 200 and 200M

... ça pue... non pas que la carte ne soit pas supportée de manière générale, mais là, tout de suite, avec ce driver, c'est cassé... faudrait attendre une autre version... là, dri n'essaye même pas de s'initialiser...

... quant à faire avec fglrx, c'est en dehors de mes connaissances, à l'origine, par choix, maintenant, parce que ça fait tellement longtemps que je ne veux plus y toucher, même de loin, que je ne le connais plus.

... sorry...

Link to post
Share on other sites

×
×
  • Create New...