Jump to content

Archived

This topic is now archived and is closed to further replies.

SAM77

Pas de connexion internet sur le poste IPCOP

Recommended Posts

Bonjour à tous

il ya plus de 3 mois que je suis sur la configuration de serveur ipcop j'ai tout fais presque jusqu'là pas d'internet

j'ai un routeur ADSL SAGEM 1500FG que j'ai mis en mode RFC1483 Bridgé

DHCP activé, lan sur sur 192.168.1.1

Infos de mon FAI : Protocole PPPOA - Encapsulation VCMUX 8/35 - DHCP - login et mot de passe pour la connexion, mais pour le nom du hôte DHCP je ne sais pas parce. Avec la commande nslookup j'ai pus avoir ça www.samrouter.com, comme nom de hôte DHCP de mon FAI.

j'ai installé ipcop sur un labtop hp nx9010 en equipant d'une deuxième interface pmacia-rj 45. toutes les carte ont étés reconues par ipcop.

j'ai donné à RED comme ip 192.168.1.2 pendant que le routeur adsl est en 192.168.1.1 et pour interface vert 192.168.0.254

nom de hôte de la machine: VPNSAM

Nom de domaine: samousam.dyndns.org que j'ai crée pour renseigné le routeur adsl

nom de hôte DHCP: www.samrouter.com, que j'ai rélevé en tapant la commande nslookup

le serveur dhcp: début : 192.168.0.1 et fin 192.168.0.254.

je me connecte sur l'interface web sans problème en 192.168.0.254: 81 j'arrive à verfié les parametréges et modifié souvent selon les coneil que je coleté sur les forum

pour les ping

sur le poste vert 192.168.1.1 ça passe

sur le poste ipcop 192.168.0.200 et 192.168.1.1

Interface se connecte de plus de 7 m en m'indiquant que :

adresse ip: 192.168.1.2

nom de hôte ipcop: rien

question:

1. comment pour avoir internet sur le vert

2. est ce que le 445 peut bloque accès internet lorsque ce port est bloque par mon FAI ce que j'ignore

3. Est ce que ma onfiguration est bonne parce à cahque fois que je regarde sur le journal je constante que mon domaine ne passe pas il es ttoujours à faillir, c'est le m^me domaine que j'utilise pour l'autre routeur qui est en serice actuellement mais à chaque essai je déconnecte l'autre.

je compte sur vous tous

Link to post
Share on other sites

Je vais peut-être dire une connerie, mais si ton routeur est en dhcp (ce qui semble être le cas puisqu'il te donne une adresse classe C privée), tu n'arriveras pas à utiliser un service de dns dynamique pour acceder à ton ordi depuis l'extérieur à moins de faire du port fowarding directement sur le routeur. à ce rythme là, autant le mettre en brigde, tu ne te sers pas de ces capacité de routage...

autre chose : comment est ta table de NAT ? si tu ne nat rien, y a peu de risque que tu puisse accéder à internet depuis ton réseau privé...

Enfin, vire les majuscule dans le titre, s'il te plaît, ça pique les yeux et c'est peu encourageant pour te répondre :transpi:

Link to post
Share on other sites

Je vais peut-être dire une connerie, mais si ton routeur est en dhcp (ce qui semble être le cas puisqu'il te donne une adresse classe C privée), tu n'arriveras pas à utiliser un service de dns dynamique pour acceder à ton ordi depuis l'extérieur à moins de faire du port fowarding directement sur le routeur. à ce rythme là, autant le mettre en brigde, tu ne te sers pas de ces capacité de routage...

autre chose : comment est ta table de NAT ? si tu ne nat rien, y a peu de risque que tu puisse accéder à internet depuis ton réseau privé...

Enfin, vire les majuscule dans le titre, s'il te plaît, ça pique les yeux et c'est peu encourageant pour te répondre :transpi:

[/quot

Mon routeur est bridgé mais je comprend rien dans cette notion de bridgé, non seulement je mes en bridge le dhcp reste activé puis le lan sur 192.168.1.1

Pour la NAT j'ai seulement activé rien d'autre. Est ce que je dois faire autre chose qu'activé au noveau de la nat, si oui quois?

comprend moi je ne suis pas pro et puis c'est ma premiere fois pour cette genre de configuration .

INFO PLUS

au niveau de interface web de ipcop partie interface pour la connexion je ne vois rien qui corespondant à mon routeur adsl, seulement je choisis Eagle USB ADSL (acer,........sagem usr) adsl est sagem 1500fg

à plus

Link to post
Share on other sites

salut à tous quelcun pour m'aide par skype je lui enverai les étape en fichier jpg

mon ipcop ne chope pas adresse ip de mon routeur

comme je suis obligé de resté en pppoa j'ai donneé 192.168.1.1 à mon adsl et 192.168.1.2 ip du RED pendant l'installtion de ipcop lorsqu'il se connecté je vius 192.168.1.2 et jamis internet

ou si quelcun pourais m'explique comment bien configuré ipcp sur dhcp

NB: je ne peux pas changé de protocole donc mon routeur ne peut pas être en mode bridge parce mon FAI ne support pas d'autre protocole que PPPOA. je sui en afrique centrale.

Link to post
Share on other sites

SAM77,

Sache qu'en france c'est pppoe qui est utiliser. Ton routeur doit faire office de serveur DHCP normalement, tu n'as qu'a t'y placer comme client. Au pire vérifie ton ppp.conf est configure le en ayant mit ton login/password que ton FAI ta transmit.

Exemple sous OpenBSD 4.1 -stable #charlie

1.ifconfig

je relève mon interface réseau: xfp0

2. sous openbsd c'est que je fais dans mon cas en attendant mon soekris :D je crée ce fichier => vi /etc/hostname.xfp0

étant vide j'écris dhcp, ensuite sauvegarde et quitte (:wq)

3. sh /etc/netstart

ca marche! j'y suis connecté par le serveur DHCP que le routeur a, qui lui fonctionne indépendamment du système d'exploitation. Sans blague! 30secondes de configuration pour accèder à internet.

Link to post
Share on other sites
SAM77,

Sache qu'en france c'est pppoe qui est utiliser. Ton routeur doit faire office de serveur DHCP normalement, tu n'as qu'a t'y placer comme client. Au pire vérifie ton ppp.conf est configure le en ayant mit ton login/password que ton FAI ta transmit.

Exemple sous OpenBSD 4.1 -stable #charlie

1.ifconfig

je relève mon interface réseau: xfp0

2. sous openbsd c'est que je fais dans mon cas en attendant mon soekris ;) je crée ce fichier => vi /etc/hostname.xfp0

étant vide j'écris dhcp, ensuite sauvegarde et quitte (:wq)

3. sh /etc/netstart

ca marche! j'y suis connecté par le serveur DHCP que le routeur a, qui lui fonctionne indépendamment du système d'exploitation. Sans blague! 30secondes de configuration pour accèder à internet.

salut excuse moi je n'ai rien compris finalement l'autre me dit une solution l'autre me dit que pppoa n'esiwte plus que est ce je dois faire

je connais rein en linux je suis débutant, je voulais savoir comment configuré ipcop avec le protocole PPPOA et avoir l'internet.

je compte sur vous merci à plus

Link to post
Share on other sites

Si tu n'utilises pas la RFC 2516 (pppoe) et que tu utilises la RFC 1483 (pppoa) comme tu l'as décrit c'est que tu dois l'utiliser.

Le standard PPP en afrique du sud est-il le même qu'en france? (Encapsulation VCMUX 8/35)

As tu réaliser le fichier resolv.conf dans /var/ipcop/red/resolv.conf ?

As tu paramètrer le fichier /etc/ppp/ppp.conf? d'ailleur tu peux même le nettoyer si il est plein pour ne laisser place qu'a la section pppoA

As tu configurer ta carte ethernet? est elle activer? (UP, RUNNING)

As tu vérifier le routage entre la passerelle par défaut et le vert comme je te l'ai demandé?

As tu paramètrer la passerelle par défaut étant 192.168.1.1 si je ne me trompe?

As tu visionner par une page HTLM les paramètres de ton routeur?

Link to post
Share on other sites

Oulà... ça m'a l'air confus tout ça...

Tu dis que ton modem(aussi capable de faire routeur, d'après ce que je comprends) a l'adresse "192.168.1.1"? C'est bien de lui que vient l'ADSL? Si c'est le cas, peu importe pour ta passerelle ipcop que tu sois en PPOE, PPOA ou autre...

De deux choses l'une: soit ton modem ne fait pas routeur (ou plus généralement, tu ne veux pas qu'il le fasse, ce-qui-est-le-bien ;)), et auquel cas, pas besoin de lui donner d'adresse IP, vu qu'il servira juste de pont entre ta machine ipcop et ton fournisseur d'accès... dans ce cas, pas besoin de définir d'adresse IP non plus sur le serveur ipcop pour le port qui est relié à ton modem... par contre, il faut que tu déclares que ce port va servir à faire tourner un démon PPP, en lui renseignant ton login, ton mot de passe, et les paramètres de modulation (VCMUX 8/35)... normalement, tu choperas une adresse IP externe automatiquement par le DHCP de ton FAI (qui devrait en profiter pour te filer des adresses de DNS, servant à faire de ta passerelle ipcop un relai DNS, pour la résolution automatique des noms de domaine, ie associer "www.google.fr" à une adresse IP en dur), et ce, grâce à la connexion PPP, et sans demander de DHCP comme tu le ferais pour les clients de ton réseau local...

De l'autre (chose ;) ), ton modem fait routeur: dans ce cas, ne t'occupe pas de configurer un démon PPP sur ton ipcop (ie, tu te fouts de ton login, de PPOE et PPOA... du moins, sur ton ipcop): configure ta connexion à partir de ton modem (s'il fait routeur, il a sûrement une interface web, à laquelle on ne peut pas accéder s'il est en mode bridge via PPP, vu qu'il n'a pas d'IP, puisqu'il joue le rôle d'un pont entre ton ipcop et ton FAI)... par contre, met l'interface de ton ipcop branchée au modem et le modem dans le même sous-réseau (par exemple, 192.168.1.1/24 pour le modem et 192.168.1.2/24 pour le port internet d'ipcop) si tu gères les adresses en statique (ie sans DHCP avec ton FAI), ou plus simple (enfin, façon de voir... qui n'est pas la mienne), active le serveur DHCP sur ton modem et le client DHCP sur le port internet de ton ipcop...

Mais si tu déclares des adresses et que tu mélanges ça avec du PPP (je ne connais pas ipcop, et ça me paraît déjà bizarre que ce soit possible), c'est sûr, ça ne risque pas de marcher...

Par contre, si tout ce que j'ai dit est du chinois pour toi, c'est qu'il risque de te manquer de sérieuses notions de réseau... et là, tu n'es pas sorti... je ne peux que te conseiller de lire quelques bouquins à propos de TCP/IP (au moins les premiers chapitres, pour comprendre de quoi il retourne, principalement les notions de réseaux/sous-réseaux, de routage [ça en découle], et de bridge [pour ne pas confondre]... c'est le minimum pour se lancer dans un truc genre ipcop en routeur de tête... il y a aussi de bons guides sur le web)... si en lisant ça, il y a quelque chose qui t'échappe vraiment, n'hésite pas à demander non plus...

Edit : et pour les domaines, ne met pas la charrue avant les boeufs... commence par mettre un nom de domaine bidon et qui ne servira que sur ton réseau local... une fois que tout marchera et que tu auras compris pourquoi, il sera largement temps d'activer du dyndns pour que l'extérieur puisse te joindre, même si tu n'as pas d'adresse IP internet statique, même si ton FAI ne t'a pas fourni de domaine (ce qui n'est, il faut l'avouer, pas courant dans les abonnements de base, en France en tout cas)...

Edit2 : @H3dy... Sam77 a l'air de débuter, et à mon avis, même s'il doit y avoir un SSH sur son ipcop quelque part, l'essentiel de la configuration doit se faire via une interface web... je ne suis pas sûr que tout trifouiller en shell (enfin, des trucs aussi généraux que le PPP et les sous-réseaux) soit ce qu'il y ait de plus simple pour lui... pour commencer du moins (parce que oui... c'est bien plus simple en shell, en effet... quand on sait ce qu'on fait, ce qu'on veut avoir et qu'on a l'habitude)...

Link to post
Share on other sites
Si tu n'utilises pas la RFC 2516 (pppoe) et que tu utilises la RFC 1483 (pppoa) comme tu l'as décrit c'est que tu dois l'utiliser.

Le standard PPP en afrique du sud est-il le même qu'en france? (Encapsulation VCMUX 8/35)

As tu réaliser le fichier resolv.conf dans /var/ipcop/red/resolv.conf ?

As tu paramètrer le fichier /etc/ppp/ppp.conf? d'ailleur tu peux même le nettoyer si il est plein pour ne laisser place qu'a la section pppoA

As tu configurer ta carte ethernet? est elle activer? (UP, RUNNING)

As tu vérifier le routage entre la passerelle par défaut et le vert comme je te l'ai demandé?

As tu paramètrer la passerelle par défaut étant 192.168.1.1 si je ne me trompe?

As tu visionner par une page HTLM les paramètres de ton routeur?

Merci pour votre réponse

au faite je vais de la mintenance informatique mais avec quelques petites notion je sais d'avance en terme de linus . inux je suis nul je à mon debut je dirais le premier jour de la classse.

j'utilise RFC 1483 (pppoa ) encapsulation vcmux 8/35

1. je n'ai pas réalisé le fichier resolv.con car je ne sais pa s comment

2. je n'ai rien parametré pour laisser place à pppoa parce que j'ai fouillé partout jamis de ppopoa seulemnt sur le adsl

3. oui toutes les cartes sont bonnes et elles ont étés toutes reconnues par ipcop

4. comment verfié routage entre la passerelle par defaut et le vert

5. oui je donne 192.168.1.1 pa r défaut

6. oui je verifi les paramètres de mon routeur avec une page htlm avant de le branché sur le red

je comprend moi si mes explication sont imcomprehensible, je sui à mon début

merci et à plus H3dy

Link to post
Share on other sites
Oulà... ça m'a l'air confus tout ça...

Tu dis que ton modem(aussi capable de faire routeur, d'après ce que je comprends) a l'adresse "192.168.1.1"? C'est bien de lui que vient l'ADSL? Si c'est le cas, peu importe pour ta passerelle ipcop que tu sois en PPOE, PPOA ou autre...

De deux choses l'une: soit ton modem ne fait pas routeur (ou plus généralement, tu ne veux pas qu'il le fasse, ce-qui-est-le-bien :down:), et auquel cas, pas besoin de lui donner d'adresse IP, vu qu'il servira juste de pont entre ta machine ipcop et ton fournisseur d'accès... dans ce cas, pas besoin de définir d'adresse IP non plus sur le serveur ipcop pour le port qui est relié à ton modem... par contre, il faut que tu déclares que ce port va servir à faire tourner un démon PPP, en lui renseignant ton login, ton mot de passe, et les paramètres de modulation (VCMUX 8/35)... normalement, tu choperas une adresse IP externe automatiquement par le DHCP de ton FAI (qui devrait en profiter pour te filer des adresses de DNS, servant à faire de ta passerelle ipcop un relai DNS, pour la résolution automatique des noms de domaine, ie associer "www.google.fr" à une adresse IP en dur), et ce, grâce à la connexion PPP, et sans demander de DHCP comme tu le ferais pour les clients de ton réseau local...

De l'autre (chose ;) ), ton modem fait routeur: dans ce cas, ne t'occupe pas de configurer un démon PPP sur ton ipcop (ie, tu te fouts de ton login, de PPOE et PPOA... du moins, sur ton ipcop): configure ta connexion à partir de ton modem (s'il fait routeur, il a sûrement une interface web, à laquelle on ne peut pas accéder s'il est en mode bridge via PPP, vu qu'il n'a pas d'IP, puisqu'il joue le rôle d'un pont entre ton ipcop et ton FAI)... par contre, met l'interface de ton ipcop branchée au modem et le modem dans le même sous-réseau (par exemple, 192.168.1.1/24 pour le modem et 192.168.1.2/24 pour le port internet d'ipcop) si tu gères les adresses en statique (ie sans DHCP avec ton FAI), ou plus simple (enfin, façon de voir... qui n'est pas la mienne), active le serveur DHCP sur ton modem et le client DHCP sur le port internet de ton ipcop...

Mais si tu déclares des adresses et que tu mélanges ça avec du PPP (je ne connais pas ipcop, et ça me paraît déjà bizarre que ce soit possible), c'est sûr, ça ne risque pas de marcher...

Par contre, si tout ce que j'ai dit est du chinois pour toi, c'est qu'il risque de te manquer de sérieuses notions de réseau... et là, tu n'es pas sorti... je ne peux que te conseiller de lire quelques bouquins à propos de TCP/IP (au moins les premiers chapitres, pour comprendre de quoi il retourne, principalement les notions de réseaux/sous-réseaux, de routage [ça en découle], et de bridge [pour ne pas confondre]... c'est le minimum pour se lancer dans un truc genre ipcop en routeur de tête... il y a aussi de bons guides sur le web)... si en lisant ça, il y a quelque chose qui t'échappe vraiment, n'hésite pas à demander non plus...

Edit : et pour les domaines, ne met pas la charrue avant les boeufs... commence par mettre un nom de domaine bidon et qui ne servira que sur ton réseau local... une fois que tout marchera et que tu auras compris pourquoi, il sera largement temps d'activer du dyndns pour que l'extérieur puisse te joindre, même si tu n'as pas d'adresse IP internet statique, même si ton FAI ne t'a pas fourni de domaine (ce qui n'est, il faut l'avouer, pas courant dans les abonnements de base, en France en tout cas)...

Edit2 : @H3dy... Sam77 a l'air de débuter, et à mon avis, même s'il doit y avoir un SSH sur son ipcop quelque part, l'essentiel de la configuration doit se faire via une interface web... je ne suis pas sûr que tout trifouiller en shell (enfin, des trucs aussi généraux que le PPP et les sous-réseaux) soit ce qu'il y ait de plus simple pour lui... pour commencer du moins (parce que oui... c'est bien plus simple en shell, en effet... quand on sait ce qu'on fait, ce qu'on veut avoir et qu'on a l'habitude)...

Bonsoir Aefron

1. oui j'ai un routeur adsl que j'ai donné 192.168.1.1 comme place adressage.

mon FAI ne supporte autre de pppoa puis adressage automatique (dhcp) je n'ai aps le choix c'est comme ça c'est afrique centrale , un seul FAI dans un pays si non changé de FAI mais que faire.

2. il ya une chose que je savoir avant d'avance

1 au moment ou mon routeur adsl ne peut pas être en mode bridgé seulement

pppoa

vcmux 8/35 te dhcp avec adressage

login et mot de passe pour la connexion, ces informations sont déja sur le routeur donc il se connecte méme sans être branché sur le interface red du poste ipcop.

Est 'il bon ou je dois mettre forcement le routeur en bridgé même si mon fai ne supporte pas et renseigné les informations sur ma conexion au niveau de interface wen partie connexion

j'attend votre aide d'ici là je bine lire votre message précedant

comprend moi je sui à mon début

Link to post
Share on other sites

encore une fois, le PPPOA ou PPPOE n'est pas un probleme

PPPOA est la norme la plus utilisé par les FAI en europe et partout ailleurs, on trouve encore un peu de PPPOE par ci par là (Allemagne et Portugal par ex) mais bon... ppp OE etant du ppp encapsulé dans de l'ethernet qui circule forcement sur des trames ATM juste pour ajouté qq fonctions ça ne change rien au final de ton coté

qu'est-ce que tu appelle interface RED sur IPCOP? c'est l'interface où est connecté la liaison distante (WAN)? dans IPCOP tu peux pas lui dire que la passerelle par defaut c'est l'ip de ton routeur (192.168.1.1) ? d'ailleurs si ton routeur fait DHCP, et que ton interface red est relié au routeur, tu a laissé en configuration automatique?

FAI <= (PPPOE/PPPOA) => Routeur 192.168.1.1 (dhcp) <= > Interface RED IPCOP (192.168.1.2?) <=> Interface IPCOP vers ton LAN

c'est ça?

Link to post
Share on other sites
login et mot de passe pour la connexion, ces informations sont déja sur le routeur donc il se connecte méme sans être branché sur le interface red du poste ipcop.

OK... donc, de ce que je comprends, ton modem/routeur n'est pas en bridge, mais en routeur: il s'occupe lui-même de gérer la connexion sans avoir besoin de qui que ce soit... Dans ce cas, si tu veux le laisser comme ça, ne t'occupe pas de PPP: dans ce cas de figure, ce n'est pas l'affaire d'ipcop, mais seulement du modem...

Le seul problème, vu que tu dis que le modem se connecte déjà, c'est donc de configurer ipcop comme routeur/firewall local... Pour ça, il faut déjà qu'il puisse dialoguer avec ton modem routeur: le plus simple et direct est alors de dire que ce qu'ils appellent l'interface red doit obtenir son adresse par DHCP auprès de ton modem... Il va en résulter que ton modem et l'interface red de ton ipcop seront dans le même sous-réseau (par exemple 192.168.1.1/24 pour le modem et 192.168.1.2/24 pour l'interface red)...

Après, donne une adresse dans un autre sous-réseau à ton interface verte, et place-y un serveur DHCP (a contrario de l'interface red qui fait tourner un client DHCP, dans le cas de figure que je t'ai décrit), par exemple 192.168.2.1/24... les PC de ton réseau connectés via cette interface vertes obtiendront alors automatiquement une adresse dans le réseau 192.168.2.0/24, et ça devrait alors fonctionner.

En gros, quelquelque chose du genre:

Serveur DHCP (Modem):192.168.1.1/24 ---> Client DHCP (interface rouge): 192.168.1.2/24 ---> Serveur DHCP (interface verte): 192.168.2.1/24 ---> Clients DHCP (réseau local): 192.168.2.XYZ/24

où seules les adresses des interfaces où il y a des serveurs DHCP sont déclarées manuellement, alors que celles des clients DHCP sont obtenues automatiquement (c'est bien tout l'intérêt de DHCP)...

Link to post
Share on other sites

salut à tous va bien j'ai fini de configuré le RED il se conecte mais toujours pas de net sur le poste du vert

mon RED est toujours en dhcp donc il obtient des DNS près la connexion mais pas de connexion internet sur le poste vert

voila comment mon vert est: ip manuel 192.168.0.2 masque 255 255 255 0 passerelle 192.168.2.1 parceque mon adsl est 192.168.2.1 et ipcop se conecte avec 192.168.2.2 ( DHCP est désactiver sur le vert )

je compte sur vous merci et à plus

Link to post
Share on other sites

Bonjour, je dois être a peut près dans le même cas de figure et ça ne fonctionne pas non plus, j'ai essayé énormément de configuration différente Pour tout dire je désespère mais n'abandonne pas.

En fait j'ai un modem/routeur configurer correctement puisqu'il y a internet au bout du câble rj45 droit, je veux juste intercaler entre mon modem/routeur et mon pc un autre pc dédier a ipcop et ben croyez le ou pas ! j'y arrive pas jusque la c'est normale car je débute mais le plus incroyable c'est que personne n'est capable de me donner une marche a suivre point par point par exemple basé sur ça:

http://www.ipcop.org/1.4.0/fr/install/html/initial-configuration.html

pour y arriver. (si j'en demande trop veuillez m'excuser c'est que je deviens fou...)

Comme point de départ j'ai un modem/routeur configurer pour avoir une connexion internet fonctionnel son ip est 192.168.1.1

En tout cas si qqn. veut m'aider c'est inespéré pour moi car il y a des semaines que j'y suis, des dizaine d’installation d'ipcop et plein de forum mais quedalle......

Link to post
Share on other sites

Ah vous ne le voulez pas en mode pont / bridge ? Vous voulez donc 2 routeurs en cascade ?

C'est vraiment volontaire, sachant que c'est plus difficile à gérer, ou c'est juste comme ça ?

Comment avez-vous paramétré l'interface verte ?

Link to post
Share on other sites

×
×
  • Create New...