Jump to content

Archived

This topic is now archived and is closed to further replies.

libertylive

Lenteur de Firefox....

Recommended Posts

Bonjour,

Je trouve que Firefox est très lent sous Linux... Je veux dire qu'il n'est pas aussi réactif que sous windows, loin de là!

Pourtant, je ne pense pas que cela vient de ma configuration (Athlon 64 3800+, 2 go de mémoire, en résumé).

J'ai essayé des tutos pour optimiser firefox, mais rien de spécial.....

Que puis-je faire? J'ai cru lire une fois, que Firefox était réellement plus "lourd" sous Gnu/Linux que sur Windows....

Mais à ce point là. :transpi: Il l'est surtout lorsque, par exemple, je suis sur Gmail.

Ma liste d'extensions : Adblock Plus, Flash Got, Gmail Manager, Media Player connectivity, Sage, Unplug, Cookies Safe, et Customize Google.

Merci à vous.

Michael211

Link to post
Share on other sites

tu a oublié de preciser ce que tu entend par lenteur, de quelle version de firefox tu parles, sous quel distrib etc

ça peut etre un probleme de conf reseau, de conf linux, ou un des nombreux plugins que t'a qu'est mal codé (essaye deja sans tout ça)

Link to post
Share on other sites

Excusez-moi pour le manque de précision. :ouioui:

Je tourne sous Fedora 7, et j'utilise Firefox 2.0.0.5.

Par lenteur, je ne parle pas de lenteur à afficher les pages (cela marche très bien), mais plutôt sa lourdeur, par exemple, à afficher un deuxième onglets, à descendre le long d'une page...

Il lui faut un temps de réaction plus qu'exaspérant (on me dira, pourquoi ne pas changer de navigateur? Parce que je veux garder Firefox!

Je l'ai essayé via le mode sans échec, mais rien ne change...

Mais, aussi bizarre soit-il, cela le fait surtout sur certaine page! Exemple, Gmail, Jeuxvideo.fr!

Aucune idée pourquoi!

Link to post
Share on other sites

jsuis aussi sous fedora 7, meme firefox que toi et aucun probleme, j'utilise gmail quotidiennement

jvois pas trop, si c'est le scrolling des pages qu'est lent peut etre les pilotes de la carte video faut voir...

Link to post
Share on other sites

C'est bizarre... J'ai pourtant réinstaller Fedora (Car j'ai changé de DD), mais toujours la même chose...

Peut-être devrais-je changer tout simplement de profil? Le supprimer pour qu'il puisse en recréer un autre? (Je le garde depuis longtemps, pour pas perdre mes paramètres,etc...)

Link to post
Share on other sites

ça y'est, un nouveau profil a été créé.

Cela a arrangé un peu les choses.

La lenteur devient acceptable, je m'en contenterais...

Peut-être un espoir avec Firefox version 3? J'ai entendu dire qu'il était plus léger (à prendre avec des pincettes bien sûr... :D )

Merci à vous

Link to post
Share on other sites

voila donc surement un plugins qu'a foutu le bronx

enfin bon jsais pas firefox ça tourne niquel, surtout sous linux.

Sinon je sais pas ce qu'on peut attendre du 3 mais ya deja des versions à tester. Le moteur est deja suffisement rapide, peut etre qu'ils vont ameliorer la gestion de la mémoire. Ya aussi la feature qui mixe historique et favoris qui devrait etre inclue dans le 3, tout ça stocké dans du SQLite il me semble histoire de pouvoir faire plein de requetes dessus :craint:

Link to post
Share on other sites

D'après mes tests vite faits, il semblerait que AdBlock avec une liste longue comme le bras soit la cause des ralentissements.

J'essaye AdBlock+ (avec des listes de regex) et ça va mieux.

Sinon plutôt que de renommer son .mozilla, essayez "firefox -safe-mode" comme dit plus haut (ça désactive toutes les extensions et les thèmes). Et après essayez sans safe-mde en désactivant une par une les extensions dans le gestionnaire d'extensions :transpi:

Faudrait voir aussi les options X11 si y'a des trucs qui peuvent être intéressants. ("firefox --help").

Quand au truc du "désinstalle tout et reconfigure tout", ça fait trop Windows pour que j'adhère à ça ;)

Link to post
Share on other sites

Sinon je confirme que Firefox3 a l'air plus rapide, bon je n'utilise pas Firefox tous les jours mais de temps en temps quand même, et c'est l'impression que j'ai (avec la alpha7), peut-être à cause des widgets natifs dans les pages. Le texte a l'air rendu un peu différemment aussi.

Link to post
Share on other sites
D'après mes tests vite faits, il semblerait que AdBlock avec une liste longue comme le bras soit la cause des ralentissements.

J'essaye AdBlock+ (avec des listes de regex) et ça va mieux.

Sinon plutôt que de renommer son .mozilla, essayez "firefox -safe-mode" comme dit plus haut (ça désactive toutes les extensions et les thèmes). Et après essayez sans safe-mde en désactivant une par une les extensions dans le gestionnaire d'extensions :D

Faudrait voir aussi les options X11 si y'a des trucs qui peuvent être intéressants. ("firefox --help").

Quand au truc du "désinstalle tout et reconfigure tout", ça fait trop Windows pour que j'adhère à ça :cartonrouge:

Je ne désinstalle pas, je supprimme seulement le profil :byebye:

Sinon, pour les options, je n'ai pas la capacité à savoir laquelle peut nous être utile.... :D

Les voici :

X11 options

--display=DISPLAY X display to use

--sync Make X calls synchronous

--no-xshm Don't use X shared memory extension

--xim-preedit=STYLE

--xim-status=STYLE

--g-fatal-warnings Make all warnings fatal

Tu peux essayer de lancer firefox en désactivant pango :

$ MOZ_DISABLE_pango=1 /usr/bin/firefox

En clair, cela change quoi? Je veux dire, à quoi sert Pango?

Sinon je confirme que Firefox3 a l'air plus rapide, bon je n'utilise pas Firefox tous les jours mais de temps en temps quand même, et c'est l'impression que j'ai (avec la alpha7), peut-être à cause des widgets natifs dans les pages. Le texte a l'air rendu un peu différemment aussi.

Bonne nouvelle alors! :smack:

Link to post
Share on other sites

Tu peux essayer de lancer firefox en désactivant pango :

$ MOZ_DISABLE_pango=1 /usr/bin/firefox

En clair, cela change quoi? Je veux dire, à quoi sert Pango?

C'est pour afficher des caractères internationaux. Par contre c'est vachement lent, donc si tu sens un manque de fluidité lorsque tu scrolles, ça vient de là.

Link to post
Share on other sites

en creusant un peu ton probleme j'ai remarqué qu'ya apparement un vrai probleme de lenteur sous firefox 2, en parcourant les bugs (du moins ceux sur remonté chez redhat) ça fait meme peur.

On y trouve des urls bien sympa à tester, certaines qui ont un refresh automatique, te font gonfler firefox en mémoire de maniere assez inquietante (genre jsuis passé a plusieurs centaine de Mo en moins d'une heure). Memory leak evident.

Pour le scrolling lent c'est plus flou, yen a qui disent que ça vient de Xorg, d'autre des pilotes (surtout nvidia, dans la partie 2D, et eventuellement sur les machines multiproc). J'ai testé qq URLS qui font en effet bien mouliner le CPU si on s'amuse a scroller de bas en haute assez rapidement.

En tout cas c'est evident que FF2 n'est pas tres clean. Heureusement c'est tres limité, le memory leak est souvent associé a des pages utilisant (mal) du code javascript, et pour le scroll lent peut etre des boites bien surchargées coté mise en page.

Ces problemes etaient bien moins presents dans FF1.5. On espere qu'ils seront vite corrigés (si c'est bien FF qui pose probleme). Et j'ai pas de windows sous la main, mais il est du coup possible en effet que ces problemes n'existe pas sous windows (surtout concernant le scrolling). C'est un comble pour un logiciel libre :D

Link to post
Share on other sites
Merci pour l'info! :D

Mais il faut, à chaque fois, faire cette commande? Ou est-il possible de configurer de sorte, qu'à chaque lancement, cela soit fait automatiquement?

Peut-être qu'en ajoutant dans ton .bashrc ou dans /etc/profile pour que ça fonctionne pour tous les utilisateurs ( je ne suis pas sûr de mon coup ) :

export MOZ_DISABLE_pango=1

Tu as ressenti une différence sans pango ?

Link to post
Share on other sites
Merci pour l'info! :transpi:

Mais il faut, à chaque fois, faire cette commande? Ou est-il possible de configurer de sorte, qu'à chaque lancement, cela soit fait automatiquement?

Peut-être qu'en ajoutant dans ton .bashrc ou dans /etc/profile pour que ça fonctionne pour tous les utilisateurs ( je ne suis pas sûr de mon coup ) :

export MOZ_DISABLE_pango=1

Tu as ressenti une différence sans pango ?

C'est minime...

Personnellement, le lag du scroll vient du fait que ma vieille radeon mobility 9000 sous XGL/Beryl est un peu (beaucoup) faiblarde...

LSP, le manchot qui sert à rien

Je possède une 7600gt :francais:

Même si avec les jeux, elle a du mal avec certains, Beryl fonctionne parfaitement!

Link to post
Share on other sites

C'est légèrement lent, quoique je deja vu pire! ;)

Donc, si je lis ton post sur la page d'avant, madko, cela viendrait des drivers?? aïe... Je vais pas les enlever, sinon je ne pourrais pas profiter de l'accélération 3D!

C'était bien des drivers que tu parlais? :chinois:

Link to post
Share on other sites

×
×
  • Create New...