Jump to content

Archived

This topic is now archived and is closed to further replies.

pipa

[Résolu] poste de travail sur Edgy

Recommended Posts

Salut à tous,

Je viens d'installer Edgy et je constate l'absence sur le bureau et dans le Poste de travail , des partitions non-linux (contrairement à ce qui était, semble-t-il, de règle sur Breezy)

Peut-on résoudre ce problème, et de quelle manière ?

Merci :-D

Link to post
Share on other sites

étonnant que les partitions ne soient pas montées automatiquement...

première manip : tu vas dans système > administration > GNOME partition editor, ca te listeras les partitions existantes... tu devras normalement voir une (ou plusieurs suivant ton système) partition de type ntfs ou fat32, et tu remarqueras qu'il n'y a pas de cadenas dessiné à coté du rectangle de couleur, donc dans ce cas : un clic droit sur la ligne puis tu cliques sur activer la partition... reste à voir si cette manip perdure au prochain boot ou si ce n'est bon que pour la session...

deuxième manip : lire ceci

Link to post
Share on other sites

Salut fredragon ,

Pas trouvé GNOME partition editor; en revanche tu m'as donné un excellent tuto qui m'a permis de créer ce que je souhaitais.

J'aurais désiré, en outre,"enfermer" mes partitions Windows dans un dossier "My_PC", sur le bureau, mais je n'y suis pas parvenu.

Je te remercie infiniment, pour ce coup de main

Link to post
Share on other sites

truc étrange, depuis ma migration en 6.10, la partition de swap n'est pas active au démarrage... obligé de passer par gnome partition editor et de faire "activer la partition machin"... je ne vois pas d'erreur dans le fstab, si ce n'est que lors de la migration, les /dev/hd* ont été remplacés par des séries de chiffres et lettres qui ne sont pas franchement compréhensibles... ca risque de chier si je remet les /dev/hd* qui vont bien à la place??

Link to post
Share on other sites

Ouais ces trucs c'est franchement un peu naze. Voilà mon fstab peut-être que ça peut t'aider.

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>	   <options>	   <dump>  <pass>
proc			/proc		   proc		 defaults		0	   0
# /dev/sdb5 -- converted during upgrade to edgy
UUID=4991c71a-ad2c-47c3-a05b-1d52385fc2e0 / reiserfs notail 0 1
/dev/sdb1	   /media/winxp	ntfs		 ro,users,noauto,defaults,nls=utf8,umask=007,gid=46 0	   1

# /dev/sdb3 -- converted during upgrade to edgy

# /dev/sdb6 -- converted during upgrade to edgy
UUID=f6f19ef2-3f29-45b3-be1f-d2456b401d8f none swap sw 0 0
/dev/scd0	   /media/cdrom0   udf,iso9660  user,noauto	 0	   0
# /dev/sda1 -- converted during upgrade to edgy
UUID=185a266e-e9e7-4f78-b88a-b51eb2aa6b12 /home/dae/stuff ext2 defaults 0 0
# /dev/sda2 -- converted during upgrade to edgy
UUID=d172407b-1d0c-463d-8a31-15be967725fd /home/dae/multimedia ext2 defaults 0 0
/dev/sda3	   /media/wingames	ntfs	  ro,users,noauto,defaults,nls=utf8,umask=007,gid=46 0	   1

Link to post
Share on other sites

oui voila, chez moi ca donne ca :

# /etc/fstab: static file system information.

#

# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0

# /dev/hda6 -- converted during upgrade to edgy

UUID=70f396d1-dffe-43ae-8426-3cb319260d01 / reiserfs defaults 0 1

# /dev/hda2 -- converted during upgrade to edgy

UUID=69f2f60b-6c50-4824-911b-7b2d608c8a98 /boot ext3 defaults 0 2

# /dev/hda7 -- converted during upgrade to edgy

UUID=5d6d4bee-19b5-498f-8a10-c5204d7cc198 /home reiserfs defaults 0 2

# /dev/hda8 -- converted during upgrade to edgy

UUID=849d917e-c5bd-479f-be59-61f42fc45396 /media/stockage reiserfs defaults 0 2

# /dev/hda1 -- converted during upgrade to edgy

UUID=907CB8737CB85626 /media/hda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

# /dev/hda9 -- converted during upgrade to edgy

#UUID=9690da72-398b-4830-9cf9-2dc41f8ab5b5 /media/gentoo ext3 defaults 0 2

# /dev/hda10 -- converted during upgrade to edgy

UUID=c43b2940-d723-4b70-9d11-9d15750824d8 /media/DSL ext3 defaults 0 2

# /dev/hda5 -- converted during upgrade to edgy

UUID=304f268c-05e7-4ec9-b712-6b95ce18ce99 none swap sw 0 0

/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0

je sais pas trop à quoi correspond ces valeurs à la noix...

exemple de ce week end : la partition /dev/hda9 que je réserve à gentoo, était formatée en reiser4 avant la migration sous edgy... j'ai voulu la reformater en ext3 depuis gnome partition editor sous ubuntu (une lubbie en passant, bref...) et la, bim, au redémarrage suivant, message d'erreur concernant cette partoche pendant le boot, puis impossibilité de lancer une session (il me proposais de prendre / comme étant la partition /home/fredragon mais meme la, impossible).

solution pour m'en sortir : commenter la ligne correspondant à cette partition (tu peux le voir ci-dessus) et hop, ca passe tout seul! d'ou ma question de remettre /dev/hd* à la place de ces séries de chiffre à la noix... (ca permettrait peut etre de décommenter la ligne sans que ca déconne?)

Link to post
Share on other sites

Salut à tous,

Merci à tous , pour vos réponses au sujet de la création d'un dossier comprenant les partitions non-Linux, sur le bureau.

Je ne suis pas arrivé à créer des liens vers ces partitions (dansle menu contextuel, la mention "créer un lien", est grisée...)

Mettre dans le dossier en question, les partitions, mange beaucoup trop d'espace-disque.

Link to post
Share on other sites

Salut à tous,

Merci à tous , pour vos réponses au sujet de la création d'un dossier comprenant les partitions non-Linux, sur le bureau.

Je ne suis pas arrivé à créer des liens vers ces partitions (dansle menu contextuel, la mention "créer un lien", est grisée...)

Mettre dans le dossier en question, les partitions, mange beaucoup trop d'espace-disque.

C'est normal, il faut être en root pour faire un lien dans le même dossier (celui ou t'es en tout cas)

T'as plein de solutions. La meilleure c'est d'ouvrir ton terminal, de faire

ln -s [tondossier] [lieu_du_raccourci]

Sans les [ ] .

Il va faire un lien symbolique contrairement si tu faisais un simple "ln truc truc" où il crée un lien "hardware". Tu peux trouver de la doc à ce sujet ;)

Link to post
Share on other sites

Bonsoir Daemonium ,

C'est Ubuntu soi-même qui les qualifie ainsi, dans une fenêtre qui ne me laisse pas d'autre choix que d'abandonner (annuler) l'utilisation de ces liens agrémentés d'un cadenas fermé.

Link to post
Share on other sites

Les valeurs a la noix sont obtenue avec la commande vol_id sur le disque.

ok, c'est bien ce que je pensais... lorsqu'on formate dans un autre format de fichier une partition (via gnome partition editor) le UUID change, sans que la modif soit reportée dans le /etc/fstab!

du coup, j'ai utilisé ta commande

vol_id -t -l -u /dev/hda9

(hda9 étant la partition me posant problème), j'ai ensuite pris le numéro sorti pour le coller à la place de l'UUID présent dans le fstab. un décomment de la ligne, on redémarre, et hop, ca marche nickel! :roll:

dernier point, je ne comprend pas pourquoi ce c :D de ubuntu ne veux pas m'activer la partition de swap?? (avec 1Go de ram, j'ai de quoi faire,mais bon, on sait jamais...) je suis obligé de passer par gnome partition editor > clic droit > activer la partition d'échange... en automatique cay mieux, non? (et c'était le cas avant de migrer en 6.10, au passage)

Link to post
Share on other sites

peut être en changeant les options de ta ligne concernant le swap

UUID=304f268c-05e7-4ec9-b712-6b95ce18ce99 none swap sw 0 0

par du plus standard comme

UUID=304f268c-05e7-4ec9-b712-6b95ce18ce99 swap swap default 0 0

:D

Link to post
Share on other sites

peut être en changeant les options de ta ligne concernant le swap

UUID=304f268c-05e7-4ec9-b712-6b95ce18ce99 none swap sw 0 0

par du plus standard comme

UUID=304f268c-05e7-4ec9-b712-6b95ce18ce99 swap swap default 0 0

:-D

testé la modif...

mais ca n'a rien changé! :D

edit : zut, j'ai juste fais "swap swap", mais j'ai laissé sw au lieu de mettre default... je retest!

edit2 : flute de aaarg! toujours pas, malgré la modif!! :mdr::zarb::roll: :frown:

Link to post
Share on other sites

ce n'est pas impossible... je ne suis pas sur de savoir comment faire pour vérifier, mais je me pencherai dessus des que possible (je serai pas dispo ce soir, donc vendredi soir).

c'est un peu étonnant, si c'est ca, que la migration ait désactivé ce genre de chose, c'est ballot quand meme...

juste un truc, j'ai été voir sur ubuntu-fr.org à la rubrique fstab, y a pas trop d'explications sur les options diverses, mais dans leur exemple, on vois "none swap sw" et pas "swap swap default"... faudra que je fouille voir pour plus d'explications, mais a priori, le problème ne viendrai pas de ces options...

merci pour ton aide en tout cas! :francais::-D

Link to post
Share on other sites

Au niveau des options ton fstab est bon, j'ai la même chose.

# /dev/sda5 -- converted during upgrade to edgy
UUID=10b85b51-e366-49bd-bea0-3c22d4340ee0 none swap sw 0 0

As-tu essayé de recréer ta partition avec gparted, fdisk ou mkswap ? Ensuite comparer ton fstab avec les infos données par la commande vol_id, et change les si c'est nécessaire.

Pour le script d'init, regarde du coté de /etc/init.d/checkroot.sh ou /etc/init.d/mountall.sh

[HS]

La prochaine cible de Bush sera peut-être les utilisateurs de Gparted au lieu de l'Iran :D:transpi:

Étant donné que GParted peut s'avérer être une arme de destruction massive, seul l'administrateur peut le lancer.

[/HS]

Link to post
Share on other sites

Salut,

En ce qui concerne la création de liens , je vais abandonner.

Ma dernière tentative, sous 'root' (sudo -s -H), la ligne de commande

ln -s.....se solde par un message d'erreur:

"Opération non permise"

Link to post
Share on other sites

×
×
  • Create New...