Aller au contenu

Personnaliser les couleurs !



Photo

[RESOLU] Mystere C++ 2010 Redistributable Package (x86)


  • Veuillez vous connecter pour répondre
19 réponses à ce sujet

#1 Israphil

Israphil

    Soldat Rebelle

  • INpactien
  • 436 messages

Posté 20 mai 2011 - 16:47

Hello tout le monde !

Alors je viens d'acheter The witcher 2, tout content j'installe, je m'aprete à lancer et.... Je reçois un premier message d'erreur :
"The programm can't start because mfc100u.dll is missing from your computer. Try reinstalling the program to fix this problem."

Je réinstalle une fois, deux fois, trois fois, quatre fois...

Hophop, je check un peu le net et je trouve cette page sur laquelle où trouve:

Problem #4: The Witcher 2 won’t launch because of error: mfc100u.dll was not found

Possible Solution #1: (by Witcher 2 tech support)

At an installation attempt a message appears:
“Launcher.exe – system error
This application failed to start because mfc100u.dll was not found. Reinstalling might help fix this problem.”

Installing the 32-bit version of Microsoft Visual C++ 2010 packet may solve the problem. The packet’s installer – a file named vcredist_x86.exe – can be found on the “Game – disk 2″ CD


J'installe donc le vcredist en question depuis le CD, et le truc, bah c'est que ça s'installe pas: ca me met un message a la fin comme quoi ca a pas pu s'installer et la raiso nest "Fatal error during installation".
Pareil si je dl depuis le site off, même problème.

J'ai un log d'erreur proposé, que je n'arrive pas a déchiffrer :

OS Version = 6.1.7600, Platform 2
OS Description = Windows 7 - x64 Ultimate Edition
CommandLine = c:\ab5f63df0a295eb45153d2a0\Setup.exe
TimeZone = Central Europe Daylight Time
Initial LCID = 1036
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft Visual C++ 2010 x86 Redistributable Setup
Package Version = 10.0.30319
User Experience Data Collection Policy: UserControlled
Number of applicable items: 3
MSI (c:\ab5f63df0a295eb45153d2a0\vc_red.msi) Installation failed. Msi Log: Microsoft Visual C++ 2010 x86 Redistributable Setup_20110520_174156351-MSI_vc_red.msi.txt
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:26).

(vous pouvez cliquer sur le msi log pour le voir).

Voilà, ça dépasse un peu trop mes compétence en la matière donc si quelqu'un peut m'aider... Merci d'avance!

#2 philosomatika

philosomatika

    Shout-Boxeur

  • ADMIN
  • 5 250 messages
  • Lieu:Nancy

Posté 20 mai 2011 - 17:19

Bonsoir,

Le message indique que vous utilisez W7-x64 et que le seul package qu'il a proposé est W7-X86.
Pour faire simple il s'agit d'un logiciel qui ne correspond pas à votre machine et il n'a pas été intégré dans l'installation...

Dans le cas présent je vous invite à installer le logiciel disponible sur cette page qui devrait compenser la lacune du setup : Ici

Ca devrait corriger le problème pour le lancement.
2013 02 21 00.25.00
Album: Craft Punk
14 image(s)
0 commentaire(s)


#3 Israphil

Israphil

    Soldat Rebelle

  • INpactien
  • 436 messages

Posté 20 mai 2011 - 18:25

Bonsoir !

Merci de la réponse rapide. J'ai suivi le lien, téléchargé et installer mais même problème "Fatal error during installation".

OS Version = 6.1.7600, Platform 2
OS Description = Windows 7 - x64 Ultimate Edition
CommandLine = c:\36f19a9eebfca14f5d8709d2665ed4\Setup.exe
TimeZone = Central Europe Daylight Time
Initial LCID = 1036
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft Visual C++ 2010 x64 Redistributable Setup
Package Version = 10.0.30319
User Experience Data Collection Policy: UserControlled
Number of applicable items: 3
MSI (c:\36f19a9eebfca14f5d8709d2665ed4\vc_red.msi) Installation failed. Msi Log: Microsoft Visual C++ 2010 x64 Redistributable Setup_20110520_191833019-MSI_vc_red.msi.txt
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:14)


(Pareil, si vous cliquer sur msi log vous pouvez voir le log complet sous fichier texte).

Je sais pas si ca aide mais voila le message exact d'erreur :
Image IPB

:(

#4 philosomatika

philosomatika

    Shout-Boxeur

  • ADMIN
  • 5 250 messages
  • Lieu:Nancy

Posté 22 mai 2011 - 08:37

Bonjour,

Chou blanc visiblement.

Plan B : je vous proppose d'injecter les dlls manquants.

Téléchargez le fichier suivant (le mdp c'est forumpci)

-Dlls.rar

Vous avez vos DLL dedant. Normalement ça devrait fonctionner en les mettant dans le dossier du jeu. Sinon il faudra les mettre dans c:\windows\system32.
2013 02 21 00.25.00
Album: Craft Punk
14 image(s)
0 commentaire(s)


#5 RinDman

RinDman

    Maître jedi

  • SUPERMODO
  • 5 812 messages
  • Lieu:Noisiel

Posté 22 mai 2011 - 08:43

Etrange j'ai les versions précédentes provenant d'autre jeux XD

Sinon prends les versions utilisés par le studio : http://www.rpgfrance...le-en-francais/

CPU : Intel Core I-5 3570K E1 ,CM : MSI Z77A-GD65 , RAM : G.Skill Ares 2x4Gb 2133mhz CAS11, CG : Zotac Geforce 670 GTX 2Go, Alimentation : LDLC BG-500W 80+, Boitier : Antec Three Hundred, HDD : WD Velociraptor 150Go, Samsung F3 1To, OCZ Vertex 2 120 Go ( still alive yes ! ), WD Caviar IDE 500 Go.

 


#6 philosomatika

philosomatika

    Shout-Boxeur

  • ADMIN
  • 5 250 messages
  • Lieu:Nancy

Posté 22 mai 2011 - 08:51

Vu le nombre de plainte qu'on voit sur le net pour ce jeu en particulier (il n'y a quand même que quelques jours qu'il est sorti), je pense que le redist qu'ils ont fait n'était pas cohérent avec les fichiers requis, ceux qui l'ont déjà ne sont pas embetés et ceux qui ne l'ont pas le sont.

D'ailleurs un moyen tout simple de s'en rendre compte :
Israphil, vois-tu des redist C++ dans tes programmes installés ? (je parie que oui)
2013 02 21 00.25.00
Album: Craft Punk
14 image(s)
0 commentaire(s)


#7 RinDman

RinDman

    Maître jedi

  • SUPERMODO
  • 5 812 messages
  • Lieu:Noisiel

Posté 22 mai 2011 - 14:34

Dans ce cas, autant utiliser ceux qui sont fourni par microsoft, il ne devrait pas y avoir de problème :fou:

CPU : Intel Core I-5 3570K E1 ,CM : MSI Z77A-GD65 , RAM : G.Skill Ares 2x4Gb 2133mhz CAS11, CG : Zotac Geforce 670 GTX 2Go, Alimentation : LDLC BG-500W 80+, Boitier : Antec Three Hundred, HDD : WD Velociraptor 150Go, Samsung F3 1To, OCZ Vertex 2 120 Go ( still alive yes ! ), WD Caviar IDE 500 Go.

 


#8 philosomatika

philosomatika

    Shout-Boxeur

  • ADMIN
  • 5 250 messages
  • Lieu:Nancy

Posté 22 mai 2011 - 16:09

C'est "standard" le package... Par contre ça s'est vu avec Stalker qu'ils avaient rajoutés des Dlls éponymes dans leur propre package et ça avait valu toute une série de bugs
2013 02 21 00.25.00
Album: Craft Punk
14 image(s)
0 commentaire(s)


#9 Israphil

Israphil

    Soldat Rebelle

  • INpactien
  • 436 messages

Posté 22 mai 2011 - 22:03

Plop!J'ai plus internet,je poste d'un café. Mais je le retrouve mardi,donc je testerais je vous re-dis tout ça.

#10 Israphil

Israphil

    Soldat Rebelle

  • INpactien
  • 436 messages

Posté 24 mai 2011 - 11:29

Hello ! J'ai retrouvé internet. Bon alors j'ai essayé de mettre le pack de DLL (merci beaucoup de me les offrir sur un plateau comme ca d'ailleurs :'); suite à ça voilà le message que j'obtiens :
Image IPB

Or, sur la faq officielle linkée par RinDman (merci aussi); il est dit que :

Si en lançant le jeu vous recevez le message d'erreur suivant :
"Launcher.exe – Application Error
The application failed to initialize properly (0xc000007b). Click OK to terminate."

Le problème peut venir de certains composant de la librairie Microsoft Visual C++ corrompu ou manquant sur votre ordinateur.
Dans la plupart des cas, il est recommandé de désinstaller toutes les version de la librairie (Visual C++ 2005, Visual C++ 2008, Visual C++ 2010) et de les réinstaller. Les fichiers nécessaire à l'installation de ces produits peuvent être téléchargés sur les sites ci-dessous.


Donc j'ai suivi le conseil j'ai désinstallé mes versions de Microsoft Visual C++ (j'avais 2 version de 2005 et plusieurs de 2008, suivis de lettre genre KMBM03). J'ai réinstallé leur package, ca marche pour 2005, ca marche pour 2008... Mais ça bloque sur 2010 :( Même message d'erreur qu'avant.

J'ai essayé 32 et 64 bit, ça ne change rien.

:mad2:


Non mais c'est pas grave je vais encadrer la boite... :pleure:

#11 philosomatika

philosomatika

    Shout-Boxeur

  • ADMIN
  • 5 250 messages
  • Lieu:Nancy

Posté 24 mai 2011 - 13:34

Tu prends bien le package depuis cette page ? : www.microsoft.com/downloads/fr-fr/details.aspx?FamilyID=a7b7a05e-6de6-4d3a-a423-37bf0912db84#RelatedResources, j'ai vu une différence de taille (minime) entre celle du ftp proposé sur le lien que tu as donné et celle de microsoft ;)
2013 02 21 00.25.00
Album: Craft Punk
14 image(s)
0 commentaire(s)


#12 Israphil

Israphil

    Soldat Rebelle

  • INpactien
  • 436 messages

Posté 24 mai 2011 - 18:03

Je ne sais pas si c'est le même, mais j'ai essayé et toujours l’éternel et sempiternel "fatal error during installation". :incline:

Merci en tout cas pour le soutien et les réponse rapides :chinois:

#13 philosomatika

philosomatika

    Shout-Boxeur

  • ADMIN
  • 5 250 messages
  • Lieu:Nancy

Posté 24 mai 2011 - 18:42

OK, ce point étant éclairci on peut agir :

Primo, désinstalle tous les packages Visual C++ que tu trouve dans "désinstaller un programme", fait un nettoyage de disque (clic droit sur le disque dur dans ordinateur -> nettoyage de disque -> cocher tout) puis redémarre de façon à faire place nette.

Télécharge ce logiciel
Il s'agit de Microsoft Installer Cleanup ; officiellement il n'est pas compatible avec 7 mais en fait il marche du tonnerre ;)

Lance avec les droits admin : msicuu.exe

Une fois qu'il est lancé tu obtiens une fenetre avec tous les programmes "installés". En descendant la liste tu devrais trouver une ou plusieurs ligne commençant par :
(All Users) Microsoft Visual C++ 2010
(All Users) Microsoft_VC90_

Il faut supprimer toutes les lignes qui commencent par ça.

Redémarre une nouvelle fois et retente l'installation du package microsoft, normalement cette fois ça devrait marcher :)
2013 02 21 00.25.00
Album: Craft Punk
14 image(s)
0 commentaire(s)


#14 foetus

foetus

    Padawan

  • INpactien
  • 1 014 messages

Posté 24 mai 2011 - 20:21

En faut l'erreur (0x80070643), "Fatal error during installation. " c'est juste parce que tu n'as pas les droits, ou alors un truc bloque l'ordinateur: Regardes ici

#15 Israphil

Israphil

    Soldat Rebelle

  • INpactien
  • 436 messages

Posté 25 mai 2011 - 10:39

OK, ce point étant éclairci on peut agir :

Primo, désinstalle tous les packages Visual C++ que tu trouve dans "désinstaller un programme", fait un nettoyage de disque (clic droit sur le disque dur dans ordinateur -> nettoyage de disque -> cocher tout) puis redémarre de façon à faire place nette.

Télécharge ce logiciel
Il s'agit de Microsoft Installer Cleanup ; officiellement il n'est pas compatible avec 7 mais en fait il marche du tonnerre ;)

Lance avec les droits admin : msicuu.exe

Une fois qu'il est lancé tu obtiens une fenetre avec tous les programmes "installés". En descendant la liste tu devrais trouver une ou plusieurs ligne commençant par :
(All Users) Microsoft Visual C++ 2010
(All Users) Microsoft_VC90_

Il faut supprimer toutes les lignes qui commencent par ça.

Redémarre une nouvelle fois et retente l'installation du package microsoft, normalement cette fois ça devrait marcher :)


Hop! Alors j'ai essayé ca. Quand je lance le cleanup par contre je trouve rien de tel (après désinstallation). Les seules lignes microsoft sont Microsoft Office et silverlight.

J'ai ré-essayer d'installer mais toujours le même soucis au pack 2010.

En faut l'erreur (0x80070643), "Fatal error during installation. " c'est juste parce que tu n'as pas les droits, ou alors un truc bloque l'ordinateur: Regardes ici


Alors si j'ai bien compris cette page, le mec dis qu'il faut mettre a jour windows au préalable, turn off son antivirus, etc. J'ai tout fait; par contre je n'avais pas remarqué mais il ya des maj Visual C++ que mon windows n'arrive pas à faire, peut être est-ce lié :

Image IPB

Et quand je double clique dessus, voilà la justification :

Image IPB

Peut être que ca n'aide pas ou n'a rien a voir mais je prefere tout décrire :transpi:

Edit 11.43: Je suis le lien "get help with this error" qui explique via l'aide windows comment régler mon problème (ce serait bien la première fois que l'aide windows regle quelque chose), je vous dis ca dans quelques minutes.

Edit 2 : Bon bah j'ai essayé e tca donne rien... Apparemment y'aurait un fichier corrompu et la solution pour regelr ça ne marche pas. Il est dit que si cela ne fonctionne pas, je dois re-installer windows. Yeah ! Si vous n'avez plus d'idées, je pense que c'est ce vers quoi je vais m'orienter :incline:

#16 foetus

foetus

    Padawan

  • INpactien
  • 1 014 messages

Posté 25 mai 2011 - 10:54

Tiens bizarre:

Erreur Windows Update 800B0001

Si l’erreur Windows Update 800b0001 s’affiche, cela signifie que Windows Update ou Microsoft Update ne peut pas déterminer le fournisseur de services de chiffrement.


Il y a justement un service chiffrement: tu l'as déactivé? :zarb:

#17 Israphil

Israphil

    Soldat Rebelle

  • INpactien
  • 436 messages

Posté 25 mai 2011 - 12:09

Aucune idée. Pas à ma connaissance. C'est quoi un service de chiffrement? :transpi:

Sinon quand je lance l'outil d'analyse sur le lien ci dessus ce me met une erreur :

Image IPB

Je suis en train de re-télécharger windows depuis le site de la fac là, tout en faisant une backup... Je vais réinstaller tout ça je pense... :craint:

#18 philosomatika

philosomatika

    Shout-Boxeur

  • ADMIN
  • 5 250 messages
  • Lieu:Nancy

Posté 25 mai 2011 - 13:33

EDIT : Avant de tenter la suite utilise ce Fix IT de microsoft qui correspond à ton problème.
Redémarre ensuite, et seulement si ça ne marche pas passe à la suite.

C'est difficile à dire sans avoir l'ordi sous le nez, même si je dois bien admettre que tu assure au niveau des captures d'écran.

Une autre pour la route :

Démarrer -> cmd -> clic droit, lancer en temps qu'administrateur

tu tapes les commandes suivantes à l'identique :
msiexec /unreg
msiexec /regserver
net stop wuauserv

Ca réinstalle en deux secondes msi installer et arrête Windows update
Ensuite tu te rend dans : C:\Windows\SoftwareDistribution\Download et tu supprime le contenu
Avec ça tu fait un nettoyage de disque : clic droit sur le disque dur, nettoyer ; tu coches toutes les cases et OK

Ensuite à nouveau commande :
net start wuauserv

Un reboot là dessus et tu reteste

Soit dit en passant, la dernière fois que j'ai vu ça c'était le disque du qui commençait à avoir des secteurs defectueux...
2013 02 21 00.25.00
Album: Craft Punk
14 image(s)
0 commentaire(s)


#19 Israphil

Israphil

    Soldat Rebelle

  • INpactien
  • 436 messages

Posté 26 mai 2011 - 10:07

Hello !

Bon alors j'ai essayé tout ça... J'ai eu aucun problème mais quand j'ai voulu installer 2010 j'ai eu encore la même erreur :craint: ...

Bref! Finalement j'ai craqué, j'ai formaté et là j'ai pu installer le pack 2010 de visual C++ sans aucun soucis. Ainsi que the witcher 2 !

Merci infiniment de l'aide apporté , je trouve plus le smiley mais : ca c'est de l'inpactatitude! :dix:

Je passe le post en "résolu" :).

#20 philosomatika

philosomatika

    Shout-Boxeur

  • ADMIN
  • 5 250 messages
  • Lieu:Nancy

Posté 26 mai 2011 - 10:20

Bonjour,

J'ai eu un autre élément de réponse entre temps : il arrive que les mises à jour s'installent dans le désordre et que celà provoque un plantage dans les mises à jour qui a pas mal de mauvaises conséquences.
En fait la solution finale aurait sans doute été de télécharger le pack d'analyse des mises à jour qui aurait sans doute résolu le problème.

Conclusion de quoi le sujet n'est pas résolu mais contourné :) :contourne:

Enfin le principal est que ça finisse par marcher !
2013 02 21 00.25.00
Album: Craft Punk
14 image(s)
0 commentaire(s)





0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)